0

How to move the cursor one character forward in iterm2? I can move one character backward with ^b. I tried ^f but instead of moving one character forward, it scroll through command history from the beginning.

  • Try this path: go to iTerm2 -> Preferences -> Profiles -> *Default -> Load Preset... in the right pane, click on it and select either "Terminal.app compatibility" or "Natural Text Editing" preset keys. For me ^f works as needed. (does ^f works for you in Terminal.app?) – Yoan Feb 7 '18 at 16:37
  • No, it does not work in Terminal.app either. Any suggestions where to change this settings? I tried to change Load Preset in iTerm2 but it behaves the same. – Franky Feb 7 '18 at 19:57
  • See this for more info: apple.stackexchange.com/questions/136928/… – Yoan Feb 9 '18 at 16:12
1

I was able to do this by going to Preferences > Profiles

Then, on the right hand side of the page, click on the Keys tab and then on the Load Preset dropdown box. Then select Natural Text Editing.

Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .