0

I have a new iMac which I am setting up. I used Migration Assistant to transfer my files from my old MacBook. Both Macs are running High Sierra.

I was attempting to open Excel2008 to edit a couple of spreadheets, and got a bizarre error message Mercer.xlsx is being modified by (my name). Open as Read-Only, or chose Notify to be alerted when it is available.

I have tried a number of things. I went to my MacBook, made sure the files and Excel were closed, copied to a portable HDD. I tried replacing the files, same result.

I opened one of the files from the HDD, and saved it to the Documents directory, and actually modified the file by adding a new line. When I tried to re-open I got the same error.

I cleared all extended attributes, but this did not seem to help. com.apple.FinderInfo 32 com.apple.lastuseddate#PS 16 com.apple.metadata:_kMDItemUserTags 42

Does anyone have any ideas. These spreadsheets contain more than 10 years worth of data.

  • You might have a hidden temporary file causing this error. Open Terminal and change directory to the folder in which your problem file is located. Type ls -al. Do you see a version of Mercer.xlsx preceded by a tilde and dollar sign? – Paul Brady Feb 7 '18 at 4:16
  • @PaulBrady Thanks - there were 3 hidden files. When I last did the TimeMachine backup the spreadsheets were open, which presumably caused the problem. – Milliways Feb 7 '18 at 5:22
  • Did you delete those files via the terminal, or did you resolve your issue some other way? – Paul Brady Feb 7 '18 at 5:37
  • @PaulBrady actually I deleted them with my own FileManager QuollEyeTree. I had to enable Hidden files to see them. – Milliways Feb 7 '18 at 6:55

You must log in to answer this question.

Browse other questions tagged .