5

I have a 2016 MBP running 10.12.6 with an external Dell 24" (P2415Q) monitor in my home office. At work I have a Dell 27" (U2717D) and a Dell 24" (U2415). At work the U27 is connected DisplayPort to USB-C and the U24 uses HDMI through an Apple branded adapter. At home the Dell is connected with a DisplayPort to USB-C.

Now the issue, sometimes when I go home (more often recently) I will plug in the external Dell 24" and it will show only a black screen. I can bring up system preferences and see that the monitor is recognized but the monitor thinks it is not getting a signal. With the message, "There is no signal coming from your computer. Press any key on the keyboard or move the mouse to wake it up. If there is no display, press the monirot button now to select the correct input source on the On-Screen-Display menu." and it shows the DisplayPort symbol in the corner indicating is on the correct input.

What I have tried:

  • Different DisplayPort->USB-C cable
  • All 4 USB-C Ports, and flipping cable
  • Changing resolution in system preferences
  • Holding option to click on "Detect Displays"
  • Restart w/display connected
  • Log in as clean new user
  • Reset NVRAM
  • Reset SMC
  • Unplug all other inputs from Dell monitor
  • Unplug power from Dell monitor
  • Yes, the monitor is on the correct input, I know it does not autodetect

Anyone have any clue? The first time this happened a few months ago I remember I actually got it fixed but I don't remember exactly how. I think it was some NVRAM/SMC reset but I have tried that this time.

UPDATE #1:

From a suggestion in the comments I have tried booting in SafeBoot which showed the same behavior.

UPDATE #2 (Next Day):

This post previously had one of my office monitors listed as a Samsung, this used to be the case but I swapped them a few months back and this problem started around the time of switchover.

I can confirm that my MBP is getting it's proverbial wires crossed somewhere as some settings I had messed with on my home P24 were in fact changed when I plugged in my office U27. So here's my hypothesis, In some way the MBP is trying to use the same output format for the P24 as it used with the U24. However, the U24 was plugged in through an HDMI adapter so it is sending an unreadable signal to the P24. I'm going to attempt to switch the U27 to HDMI and the U24 to USB-c and see if this fixes the issue, if not it could be a more serious mismatch.

UPDATE #3:

After swapping the cables and going home this did not fix the issue. I did bring my Apple HDMI to USB-C adapter and using this with the HDMI input on the P24 works. I'll be trying the shutdown at work next but I don't have high hopes. At this point this is a very reproducible issue I think I should submit it to Apple in some capacity.

  • Have you tried booting up using Safe Boot? – Jake3231 Feb 6 '18 at 16:37
  • @Jake3231 I just booted into SafeBoot (Following helpx.adobe.com/x-productkb/global/…) and observed the same behavior in safe boot. I did have to unplug and plug the monitor cable back into my MBP for it to detect in in System Prefs. Also, I did see some odd graphical errors (rows loading) and performance was extremely poor, not sure if that is to be expected. – Raab70 Feb 6 '18 at 16:48
  • Thanks for trying that! It is expected that performance will be much less than usual and there may be some graphical issues while in Safe Boot. It’s good to know that Safe Boot did not resolve the issue. – Jake3231 Feb 6 '18 at 16:49
  • I'm confused. You say you have Dell in your home office and two Dells at work. Where does the Samsung come from? When you come home and connect your Dell, are you waking your MBP from sleep or booting it from off? If from sleep, try going from "off". What adapter are you using at home? – Allan Feb 7 '18 at 13:45
  • @Allan Sorry, I've clarified. This post originally had the 24" at work listed as a Samsung. That changed a few months back to the Dell and I misspoke in the original post yesterday. – Raab70 Feb 7 '18 at 14:03

You must log in to answer this question.

Browse other questions tagged .