2

I have a live usb image that seems to run on my lenovo thinkpad that I'd like to get to work on an old iBook (Model A1007). Things I have tried so far

1) Just turning the computer on with the usb in the usb drive. 2) Holding the option key while restarting the computer 3) Following these instructuions: http://ben-collins.blogspot.com/2010/08/booting-your-ibook-g4-from-usb-stick.html

but replaced all instances of "txbi" to "yaboot"

First

In this case I booted while holding down Cmd + Option + O + F and typed:

 boot ud:,\\yaboot

This brings up a circle with a line through it icon. Maybe this means it failed to boot from the usb device so I tried the alternative walk though after a restart and the same key combenation:

 > dev usb0

which returned

dev usb0 ok

then

 > ls

returned

ff9a6d98: /disk@1
ok

then

 > dev disk@1

returned

> dev disk@1 ok

then

 pwd

returned

pwd /pci@f2000000/usb@18 ok

then

 boot /pci@f2000000/usb@18/disk@1:,\\yaboot

returned

boot /pci@f2000000/usb@18/disk@1:,\\yaboot can't open :/pci@f2000000/usb@18/disk@1:,\\yaboot

Does this suggest a problem with my usb drive? Or perhaps I am doing something wrong with this attempted way of booting from a usb. Any suggestions?

1

A quick search for Lenovo ThinkPad shows these machines use Intel processors. I believe your iBook uses a PowerPC processor. So one would expect the USB flash drive to fail to work with your iBook, if you can boot using the ThinkPad.

Appendix

Ubuntu PowerPC FAQ

Lubuntu 16.04.3 LTS (Xenial Xerus)

Ubuntu MATE 16.04.3 LTS (Xenial Xerus)

Note: iBook (Model A1007) shipped with 256 MB of RAM. This is expandable to a maximum of 640 MB.

  • Does this mean that this would likely have worked if I used a PowerPC version of Ubuntu? – ohnoplus Feb 27 '18 at 1:42
  • That would make a nice new question. However, I did find this link: Which Macs are compatible with Ubuntu? I also added, to my answer, some links of possible Power PC downloads. Lubuntu might make a better choice than Ubuntu. It really depends on how much RAM is installed in your iBook. – David Anderson Feb 27 '18 at 2:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .