32

Basically I am "at odds" with Mac OS on how to properly type my password.

Meaning: when I used Linux (ubuntu with unity to be precise), I really didn't care about the "state" of my Linux box. If the screen saver/lock was up, I just started typing my password and hit enter. And ... I was logged in. Because the Linux screen lock was smart enough to understand that the string I typed + Enter is my password.

With Mac OS, on the other hand, I have to be much more "careful". I often find myself first type a letter, and press enter, and then when the input text field starts reflecting me typing ... I slowly type my password, and carefully press Enter. Because: if I don't do that, Mac OS will try to use maybe 5 out of 8 chars I typed. Or something else. So far too often, it takes me two, three turns before I successfully unlocked my screen.

Long story short: is that me not fitting Mac OS (so I have to change my attitude of just typing pretty fast) - or are there ways to adapt Mac OS to my style of entering the unlock password?

(And yes, when I have the lid open, I use the fingerprint reader, works fine - but within the office, the lid is down.)

  • 3
    I don't have a lid, so that may complicate the issue, but for me if the screen's asleep it's tap space bar, count to 3, type pw, enter. I'm in before the screen's finished waking. – Tetsujin Feb 5 '18 at 14:42
  • 6
    This is one of the most annoying things about OS X. Especially if your the type of person who (wisely) has a long-ish password. Thanks for asking this. – Jared Smith Feb 5 '18 at 20:18
  • 3
    Windows 10 does this too. It's exceedingly annoying. It feels like it was designed by people that never type passwords. – Clonkex Feb 6 '18 at 0:30
  • 2
    @ИвоНедев I am working with the latest 2017 Mac Book Pro "Touch". Rest assured: this is a problem even on latest greatest hardware. – GhostCat Feb 6 '18 at 12:20
  • 2
    @Clonkex I was pretty sure there was a setting in the UI for there, but it seems that you need to edit the group policies (Computer Configuration -> Administrative Templates -> Control Panel -> Personalization -> Do not display the lock screen), though that may only work on Enterprise/Server versions of Windows. Another option is modifying the registry (though that will probably be reset on every larger Windows update, sigh). – Luaan Feb 7 '18 at 9:04
33

If you press the modifier keys (Command, Option, Control, Shift), it will wake the computer but not type anything, so you can press them as many times as you like without messing up your password.

I usually just drum on the modifier keys until I see the password cursor, after having exactly the problem you describe.

  • 9
    I find that the password cursor appears, yet macOS is still not ready to accept my password, so it ignores the first few keys. – Roger Lipscombe Feb 5 '18 at 19:09
  • 6
    Exactly. The most annoying thing here is that inconsistency part. – GhostCat Feb 5 '18 at 20:23
  • 1
    Incidentally, this is also the habit I have in the OPs original scenario, i.e., I (superfluosly, apparently) hit Ctrl a few times before I start entering my password ... Maybe I take the lesson from this question and stop doing that :) – Hagen von Eitzen Feb 6 '18 at 9:44
  • 1
    In particular, if your password starts with a capital letter or special character, you can keep shift held down, then type the first character once the screen turns on. It feels like you are just typing your password normally. – BallpointBen Feb 6 '18 at 22:25
  • 1
    I used to drum on the modifier keys, but everytime I did that on a Windows box, it took me into assistive mode, and then I had to do even more stuff to get out of it. So this turned out to be just as bad a habit as waking the computer with the first letter of your password. – Harper Feb 7 '18 at 1:20
13

Every time you try to enter your password incorrectly, it will reject it and highlight the incorrect try.

Solution

Mash the keyboard (type random charcters) until you see characters appear, hit enter1 (accepting you will be incorrect), and then type the correct password (which will thus overwrite the highlighted incorrect password).

1If you prefer not to hit enter (because maybe you have 3rd party software which locks you out after x attempts):

  • cmd+delete clears the whole line behind your cursor
  • option+ delete clears the whole word behind your cursor

Why this is better than other suggested methods

I find this to be the fastest way to get around MacOS not recognizing when typing starts, because you get immediate feedback on when input begins to be recognized--something you won't get if you just tap one of the modifier keys. You also don't have to needlessly wait extra time if it begins to recognize input quickly--which is what you'd have to do if you always wait 5 seconds after you wake, and before you begin typing, for example.

2

If the screen is asleep then just tap space bar (once only or the 2nd tap will be the first char of the password); then either wait until the screen wakes fully, or just count to 3, type your password, hit Enter.

It used to work if you shook the mouse first, but these days it's space bar to wake, even if it's just the screen asleep, not actually the computer itself.

0

Bad habit. Waking the screen from screen-saver with the first letter of your password is an inherently unreasonable thing to do, for several reasons. The first is that the computer may not yet have switched to the state in which the password-acceptance application is in focus, and the password box has keyboard focus.

If the password-entry box is not in focus, then what happens to your keystrokes is disturbingly unpredictable. Not least (on systems where security is an issue), it creates a huge security hole, where you have no typed your password into whatever application does have focus.

It was sloppy of Linux to allow this to work. As others have suggested, wake it up with "shift". Do not drum the shift key, or you'll be unhappy everytime you wake a Windows machine.

  • 3
    I don't buy that. I am not waking my computer. It has the screen lock up and running. I exactly know where my typing goes. ( and for the record: I am talking about my "business laptop" - which has a very well defined software stack ... this is not some windows box that sits somewhere where 5 people install all kinds of software they pick up from the internet ) – GhostCat Feb 7 '18 at 7:16
  • 1
    "typed your password into whatever application does have focus" - any OS allowing to access any application before unlocking from screen lock is broken. "It was sloppy of Linux to allow this to work" - why it is sloppy to do this assuming that lock screen works correctly (is not allowing access to any programs)? – Mateusz Konieczny Feb 7 '18 at 8:07
  • That explanation is just an excuse. You're saying the letters need to go to the lock screen while the computer is locked, which is something people agree with. You're also saying that's not possible, which is obviously incorrect: At best it's non-trivial to implement. – Peter Feb 7 '18 at 10:03
  • @Peter I don't think I'm saying that. I'm saying if you don't have positive visual feedback as to what you're typing your password into, you should not be typing your password. – Harper Feb 7 '18 at 17:54
  • @GhostCat errata noted and my apologies. I did not realise your system did not have any security risks. You should really state that as part of your question, since that is an unusual situation. I would leave this answer up, as it will help the majority of others who do have security risks. – Harper Feb 7 '18 at 17:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .