2

I have an iPhone 6s and I'm using iOS 11.2.5

I tried running a backup from iTunes, but got the following error:

iTunes could not back up the iPhone "[iphone name]" because an error occurred while reading from or writing to the iphone.

I've tried multiple computers, OSX, Windows, older iTunes, but always got the same error.

On OSX I've opened the Console app, to see what's going on in the background, and found that the following lines are logged, when the error happens [image]:

error   [date]  BackupAgent2    <private>
error   [date]  BackupAgent2    Error uploading "<private>" to "<private>": <private>
error   [date]  BackupAgent2    Backup error - <private>

I found on some forums that this error log message used to contain a filename instead of <private> (which usually were a corrupted image file) and as a user removed it on the phone, the error disappeared. But it looks like Apple suppressed a lot of things in logs.

I also found a command sudo log config --mode "private_data:on" to force display these <private> data, but this seems to work on OSX apps only, not on iPhone logs.

So unfortunately here, I came to a dead end.

Can someone help me identify the corrupted file(s), force displaying more detailed errors, or tell me anything else I can do?

  • I have tried everything you mention including the iCloud backup, all backups fail.. and I receive the same BackupAgent2[285] <Error>: Error uploading "<private>" to "<private>" if anyone has any additional thoughts they are very welcome I am running iOS13 public beta 3 on an iPhone X phone runs fine just will no longer back up but it seems this is along running intermittent issue. thanks in advance – Matt Jul 28 at 16:00
1

From what you’re describing it looks like you have a corrupted backup on your laptop, I assume deleting it will get you to backup your device. What you can do to check is follow these steps:

  1. In the Finder, navigate to your iTunes backups folder
  2. The backup folder of your device MUST contain at least the following:

    • Manifest.db or Manifest.mbdb
    • Status.plist
    • Manifest.plist
    • Info.plist

If you have any of these missing, the backup is corrupted or incomplete. In that case, simply delete this backup and start clean with a new iTunes backup.

I’m also thinking it might be worth checking if any iOS app installed on your iPhone contains files with special characters in the filename - they can cause issues while backing up (APFS related, yes…).

I’m sure you’re fine with locating the iTunes backup folder, but just in case anyone else is having trouble here’s how to get there:

  1. Open the Finder
  2. In the Main Menu > Go > Hold alt key, Library menu item appears.
  3. Click Library.
  4. Navigate to Application Support/MobileSync/Backup and locate the iPhone backup. It should be a folder named with your device UDID.
  • Thanks! Unfortunately, as I wrote, I already tried multiple computers (one never even had iTunes installed before), so I'm sure the problem is not related to corrupted backups. But about special characters in file names: How can I search for them without jailbreak, and where should I look? – frzsombor Feb 22 '18 at 22:41
  • 1
    You could go through the console logs using iMazing, while backing up your device. Since we display logs directly from the device,there’s a little chance you could get better results. Here’s our blogpost on the subject. Disclosure: I work with the iMazing team. – Al Dyniovska Feb 23 '18 at 9:01
  • I've tried your application, but got the same result :( I see the error in the log file, but the details are hidden by these "<private>" strings. Error log: pastebin.com/raw/G1JXjwiS Image: imgur.com/a/nPjPS – frzsombor Feb 23 '18 at 11:33
  • 2
    Thank you for the logs. Unfortunately, we didn’t find anything helpful there - indeed, the one relevant info is redacted, grrrr... It’s definitely a problem during upload, so the special character filenames can still be a valid guess. From what we have seen so far, navigation apps or flight path apps are often the culprits (foreign city or region names in filenames). Another guess would be that iOS is lacking space to unpack temp files. How much free space do you have available on your phone? – Al Dyniovska Feb 23 '18 at 14:14
  • I've checked the storage and my phone shows that 57.9GB of 64GB is used (so I have about 6GB free space). Also I don't have any flight app and only use Apple and Google Maps. :/ Thank you for sharing your ideas anyways! – frzsombor Mar 1 '18 at 9:57
0

As I couldn't find and solve the problem itself, I decided to pay for the 50GB iCloud storage plan, and I've been able to completely backup my iPhone (including all photos and videos) to iCloud. After that, I've restored my iPhone to factory settings, updated it to the latest iOS and restored everything from the online backup after logging into my Apple account on my phone.

Please note that I only purchased the 50GB iCloud subscription, because I have thousands of photos and videos on my phone, which is much more than the free 5GB iCloud storage can backup. But, if you only use less than 5GB storage on your iPhone, you can do the same without paying for any subscription.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .