1

Basically I want firefox to open URLs starting with "ssh://whoever@wherever" using iterm2.

Unfortunately I didn't pay attention - the first time I tried this, Mac Os suggested to use Terminal, and stupid me also clicked the checkbox to remember that setting. Now I can't figure how to undo/change that decision.

I have seen this question - but unfortunately that one is 7 years old and seems to be outdated (my preferences->profile window doesn't look at all like the one shown in the existing question).

2

To fix this, you need to delete/change the association within Firefox.

  1. Go into Firefox Preferences (hamburger menu in upper right hand corner of window or press ⌘ Command,)
  2. Scroll down to Applications. You can either scroll through or search for the association you wish to modify

    enter image description here

  3. Delete the association; the next time you click on the link it will ask you what you want to do. Or... change the association to the application you wish to be opened.

| improve this answer | |
0

For another alternative with many additional functions...

While it's been around for quite some time, nonetheless it still works.

Give RCDefaultApp, by Rubicode, a try.

enter image description here

Note: I have no affiliation with the developer Rubicode, just enjoy using this free utility.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .