3

Simple question- My mac regularly & seemingly randomly tells me it has been scheduled to go to sleep automatically- usually (I think) right after I wake it up. I have no schedule for automatic sleep set up in preferences.

When this happens I just shrug and cancel the countdown box but it is annoying. Is there any way to see what is triggering this message and fix it?

  • I assume you've gone to System Preferences/Energy Saver and checked there? – jmh Feb 3 '18 at 21:17
  • Yes, nothing sticks out when checking pmset -g either (though I don't know that area as well). This has persisted from sierra through my upgrade to high sierra. – erikdstock Feb 4 '18 at 18:58
3

If you are using iDrive that might be the culprit.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    Can someone explain this answer? I actually have iDrive and a Mac exhibiting the same symptoms, but I've gone through the iDrive settings and anything that automatically powers off/sleeps the Mac is disabled. – Danny A Sep 6 '18 at 2:45
3

I had this issue as well. I found two potential answers:

This one suggests resetting PRAM and the SMC:

https://discussions.apple.com/thread/7702633

However, the second one mentions iDrive (as did a previous answer here). I did, in fact, switch to iDrive about a month ago, and believe the dialog box began appearing after installing it:

https://discussions.apple.com/thread/8304128?page=2

The above thread refers to a response from iDrive support which suggests un-checking the "wake from sleep" setting (it is apparently checked by default; mine was). For me, the issue was completely resolved by making this change; it has been 4 months since I changed the setting with zero recurrence. Make sure you don't miss the "do you want to save changes" dialog after changing it; iDrive has a way of making macOS feel like Windows.

iDrive Setting to change

  • In my case idrive was the issue, and i stopped using it entirely for unrelated reasons. Sorry I can't be of more help. – erikdstock Jan 10 at 18:28
-2

I have had this problem since moving to High Sierra. The dialog box appears after I supposedly wake up the computer in the morning. I say supposedly, because the power light on the macmini is usually steady, indicating only the display, not the computer, is asleep. THe dialog always gives the same interval before sleep, something like 9 minutes and 28 seconds, which bears no meaningful relationship to the scheduled times in Energy Saver. It does not appear every day. I sleep the computer every night before I sleep. I have Schedule in Energy Saver set to wake the computer at 2:59 AM daily and put the computer to sleep again at 3:30 AM so it should definitely be asleep later in the morning when I get up. This Schedule is so a Launch Agent can run and download a TV schedule into EyeTV and there should be plenty of time for this to happen and the computer to go back to sleep, but it is clearly remaining awake. I have tried resetting PRAM and trashing Finder .plist with no result.

  • 1
    Welcome to Ask Different. I'm not sure if this is a me too answer or you're saying this is just a bug. Would you mind summing this up with a clear answer? Maybe it's third party so if you want to list those - that might be a great start to an answer. – bmike Jun 18 at 22:00
  • I suppose it's an answer, but not a solution. I did wish to communicate that resetting PRAM and deleting Finder prefs, sometimes suggested as fixes for this problem, did not work. I don't use iDrive, so it is not related to that. – Peter Aretin Jun 19 at 22:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .