4

I'm using the screencapture command line util to capture window contents of a MS outlook window. I have two macs, one I've had for a while and upgraded to 10.13.3 gradually; another I installed MacOS 10.13 recently from scratch.

The one I've had for a while captures all windows correctly when I run

screencapture -o -l ###

Where ### is the ID of the window gleaned from applescript. However, on the other mac, contents of the window are missing on some windows (MS Outlook and Terminal).

This is a capture of a small terminal window, all the window contents are missing

This is a capture of MS Outlook whose contents are missing

When I capture the entire screen the window contents are present. Is there a configuration option that would change whether a window's contents are returned or not? Is this a permissions issue?

Some windows capture and show their contents (Contacts App, Calendar) and some don't on the affected Mac (Finder, MS Outlook, Terminal do not) Same behavior happens with Shift-Command-4 and then space to capture a window directly.

3
  • I did an MD5 comparison of screencapture util executable between a working mac and my non-working mac and they have the same hash.
    – Richthofen
    Feb 2, 2018 at 20:53
  • Have you tried using grab and comparing results that way.
    – Natsfan
    Feb 3, 2018 at 0:24
  • So I've tried doing shift-command-4 and NOT using spacebar and drawing my own crop lines, and it works fine in that the window contents are captured.
    – Richthofen
    Feb 5, 2018 at 14:05

0

You must log in to answer this question.

Browse other questions tagged .