3

I'd like to run the latest public beta of High Sierra (10.13.4 Beta 1) in a VMWare Fusion VM.

I already have a Fusion VM running High Sierra 10.13.3, but trying to upgrade it to 10.13.4 with the App Store gets stuck just showing a black screen with the Apple logo after downloading and initiating the upgrade process (see Screenshot).

enter image description here

Normally I would just set up a new VM with the version I like to use. But I can't find a way to just download the public Beta to use it as an installation medium for the VM. Of course I can find the public Beta in the App Store of my macOS host system, too, but the App Store is only giving me the option of downloading and installing it, which is not what I want.

Does anyone know of a way to get public Beta version of macOS installed in a Fusion VM?

  • Hi, I have a similar problem. Upgrading to 10.13.4 public beta 1 works and I get a VM with a very high resolution. Scaling the window brings to a black screen (in the VM) and a stuck VM. I have to perform a "Power on to firmware" to be able to reboot. After the reboot the same situation with the wrong resolution. – Matteo Feb 14 '18 at 15:11
  • @Matteo Yes, in the meantime I got to that point, too. It's a bit annoying how difficult/badly supported macOS virtualization generally is. – anothernode Feb 14 '18 at 15:15
  • I tried with the public beta 2: same result – Matteo Feb 14 '18 at 15:54

You must log in to answer this question.

Browse other questions tagged .