2

I have some really weird auto-correction issues in Office for Mac (not sure if this also happens in other apps, as I am primarily using Office for texts).

The auto-correction changes of the to oft he and for that to fort hat. There are also other examples, but those are most common and irritating.

The system-wide auto-correction is disabled (in System Preferences -> Keyboard -> Text):

System wide autocorrection settings

The Autocorrection setting in Outlook is also disabled:

Disabled auto-correction in Outlook

I use Grammarly in Chrome, but it should not affect any system applications.

I noticed that this become more notorious once I added German and Russian to my keyboard layouts. It also had happened before, but it wasn't that irritating. Can it be somehow related? That would partially make sense, as oft is a common German word, but the auto-correction happens while I am using the US keyboard layout, not German (that I rarely use).

4
  • 3
    Apple's autocorrect should be irrelevant for Word, it has its own settings. Have you checked those? Jan 30 '18 at 20:54
  • Well, I face that problem in Outlook (I don't use Word much), but I went to Word and disabled auto-correction there too (indeed, it has a different setting), I'll see if that is going to do the trick. Jan 31 '18 at 21:03
  • Unfortunately, even after disabling everything additionally in Word I still face this problem in Outlook (I didn't work in Word enough to test this there). Feb 3 '18 at 10:28
  • Ask also in the forum devoted totally to outlook. answers.microsoft.com/en-us/msoffice/forum/… Feb 3 '18 at 13:11
1

I know this is an old post, but I think I may just have figured it out. I am using Outlook on PC, but I have had the exact same issue, such as "for the" becoming "fort he".

I have German and English languages installed and I believe this is the source of the problem (and it goes back at least 14 years if you try Google. Good bug fixing MS).

Anyway, the solution I found was to turn off "Detect Language Automatically" in the email editor. In the PC version this can be found on the Review ribbon under Language. I hope the Mac version has a similar layout.

Email Editor Language Selection

This has appeared to work so far. It's a pain because changing languages in email will require a manual flip each time, but if I can avoid oft he, fort he, fort hat, etc. then it is worth it.

Hope this helps, even so late after the fact!

0

I encountered the same problem. I have Dutch as preferred language in Outlook, English as second preference, and each time I start an email with 'thanks for the quick reply' (which, incidentally, turns out to be quite often), it gets changed into 'thanks fort he quick reply', before detecting that I've switched to English. Extremely annoying.

While turning off the automatic language detection works, I found a more convenient solution that works perfectly for me: Simply add an item to the autocorrect to 'change' the string 'for the' into 'for the'.

Add autocorrect item

Hope this still bears relevance for some.

1
  • Please note that I've encountered the issue on Windows, not mac, but I expect the solution should be universal.
    – Wlump
    Feb 19 '20 at 9:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .