2

MacOS 10.12.6

I have port forwarding in my Airport correctly configured to forward connections on port 22 of my public IP address to port 22 of my statically-assigned 10.0.1.200 MacOS. I've set the Mac's System Preferences > Sharing > Remote Login to accept connections from both myself and "Pete". Pete is remote, and is using public key authentication and can successfully ssh to my Mac. I also have public key authentication set up, but am unable to ssh in. When I look at /var/log/system.log on the Mac, I see:

Jan 30 10:03:17 xxxx sshd: chap [priv][73749]: USER_PROCESS: 73751 ttys002

and nothing else. I'm simply assuming it was my unsuccessful attempt to ssh in that triggered that message. If that's correct, then obviously port forwarding is working correctly.

I'm attempting the ssh from a Linux computer at work. Is there anything the network folks could have done at that end to cause my Mac to refuse the connection? Can anyone suggest what I might try next to further narrow the problem down?

Verbose logging:

$ ssh -vvv chap@X.X.X.X
OpenSSH_7.2p2 Ubuntu-4ubuntu2.4, OpenSSL 1.0.2g  1 Mar 2016
debug1: Reading configuration data /home/charrison/.ssh/config
debug1: /home/charrison/.ssh/config line 1: Applying options for *
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: resolving "X.X.X.X" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to X.X.X.X [X.X.X.X] port 22.
debug1: connect to address X.X.X.X port 22: Connection refused
  • This is confusing....can you ssh into your Mac from behind your firewall? In other words, can you connect when on the same network? Have you tried from another network other than work (a coffee shop or hotel?) – Allan Jan 30 '18 at 15:56
  • @Allan: I can login at home, on the same local 10.0.1.* network. I'm also pretty sure (but can't check at the moment) that I can log in from another network. – Chap Jan 30 '18 at 16:26

You must log in to answer this question.

Browse other questions tagged .