1

I have a 4th gen Apple TV using tvOS 11.2 I believe. The last week or so I've been unable to watch Netflix/Hulu/other streaming video sources on it; I can open the app for whichever service, but if I try to watch a show it either doesn't load or does load but is unable to play past a few seconds/minute at most.

I'm able to play the same video on my iPad or iPhone with no problem, as fast as I would expect it to play (no buffering), and my speed test app shows 70 MbPS, which seems fast enough. The iPad and Apple TV are connected to the same WiFi router, as far as I can tell (it's an Eero, of which I have two in the house, but Eero at least thinks they're both connected to the lower floor one as they ought to be).

I've tried the basics - restarting the Apple TV, primarily - but that doesn't seem to help at all. I also re-created the WiFi network.

Is there a likely potential cause for this? Any additional troubleshooting steps I should try before considering it's possibly hardware? I considered a factory reset and reinstall the OS from scratch, but it's not clear to me what that would necessarily accomplish unless the networking itself is faulty (as it's not isolated to just one app).

It also fails if I AirPlay streams to the AppleTV from the iPad, though as far as I can tell that doesn't seem to actually stream from the iPad directly when I'm AirPlaying Netflix/etc.

  • I think the eero has an Ethernet port. Can you wire it up to the ATV? You'll still be going over the same wifi (unless it's the eero that's also hooked up to your modem), but the ATV will use the Ethernet protocol, not wifi. This will help debug if it's the ATV's wifi. If it still fails, you don't know if it's the ATV itself, or something else in the network, but it's one variable that's easy to examine. After that, can you take the ATV to a friend's house and try it there? That will eliminate your entire network. If it's still failing there, it's the ATV or the network config in it. – jimtut Jan 30 '18 at 1:33
  • @jimtut Thanks for the suggestions. If this comes up again I will give hardwiring it a shot; that's definitely a good idea. Was hoping this was a known issue... and glad that a hard reset ended up solving it. – Joe Jan 30 '18 at 15:15
1

The solution ended up in this case being unplugging/replugging in, which worked while a soft reset (in Settings->Restart) did not.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .