3

After applying the 10.13.3 update, I am not able to open itune and xcode.

enter image description here

In lanuchpad I don't see any update is being applied to these applications

enter image description here

How can I fix this? I cannot afford to reboot again and again (There are too many applications I have to restart for work)

I have tried to download the itune installer from apple. The installer just showed an error message than quit.

enter image description here

4
  • I don't use Launchpad so I don't know how/if this usually shows up there, but if you open App Store and check under Updates, do you get any info there?
    – Lizzan
    Jan 29 '18 at 9:26
  • "No Update Available". Jan 29 '18 at 9:27
  • What about rebooting with the option to restore windows set to on?
    – Harcker
    Jan 29 '18 at 14:12
  • Rebooted numerous time. Jan 29 '18 at 21:33
2

I have the same error message with XCode.

I deleted Xcode from Finder. Emptied the trash. Then installed XCode again from the App Store. (I cannot remove iTunes because it is disallowed by macOS)

Now both XCode and iTunes work again.

2
  • Same problem here, after installing the "Command Line Tools for Xcode" update. Trashing and reinstalling the whole of Xcode fixed it for me. Thanks!
    – qris
    Apr 1 '18 at 21:47
  • I had the same issue for XCode .. turns out iTunes was being updated in the background .. wish the system informed me of this.
    – andrewz
    May 31 '18 at 15:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .