34

iCloud Drive on my Mac (10.13.3) won't sync.

  • My other devices perform perfectly, as does icloud.com. Any change made on one immediately propagates to the others.
  • Changes made to iCloud Drive on my Mac go nowhere. The cloud icon displays indefinitely. Changes aren't propagated to my other devices or iCloud.com, nor do changes made in other locations propagate to my Mac, which is lost in some orphan universe of its own.
  • All other services (i.e., Contacts, Calendar, etc.) perform perfectly.

So far I've tried…

  • Disabling/enabling iCloud Drive on all my devices.
  • Various combinations of disabling/enabling "Desktop & Documents Folders"
  • Signing out/in of iCloud on all my devices.
  • Restarting the Mac until the startup chime had me reciting Edgar Allan Poe's "The Bells."
  • Removing all files and experimenting with one small file.
  • Waiting eight hours for a 25kb startled cat photo to sync.

…all to no avail.

I've attached log entries matching…

message type:error
message type:fault
process:icloud

…below, but if there are obvious screaming errors in it, they're over my head.

I'm at wit's end. Suggestions would be most appreciated.

iCloudPreferences   error   15:45:50.464165 -0800   com.apple.preferences.icloud.remoteservice  [AOSAccounts] : ****###****-[MMMobileDocumentsService confirmUserWantsToDisableiCloudDriveAndDesktopWithDialogCompletion:] kMMPropertyMobileDocumentsiCloudDriveDisableDataclassActions  returned  (null)  uploadPending 1 downloadPending 1
iCloudPreferences   error   15:45:52.377211 -0800   com.apple.preferences.icloud.remoteservice  [AOSAccounts] :  -[MMMobileDocumentsService observeValueForKeyPath:ofObject:change:context:]: progressText got from iCloud Drive :()
iCloudPreferences   error   15:45:52.377322 -0800   com.apple.preferences.icloud.remoteservice  [AOSAccounts] :   ****###****     -[MMMobileDocumentsService observeValueForKeyPath:ofObject:change:context:]:                                                 0.0% [indeterminate]            (fractionCompleted)
iCloudPreferences   error   15:45:58.012621 -0800   com.apple.preferences.icloud.remoteservice  [AOSAccounts] : [-[MMMobileDocumentsService setEnabled:creating:withWindow:]_block_invoke_2] : showUploadDisableiCloudDriveSheetWithCompletionHandler completed with status 1
iCloudPreferences   error   15:45:58.015098 -0800   com.apple.preferences.icloud.remoteservice  [AOSAccounts] : [-[MMMobileDocumentsService uploadAndOptOutOfiCloudDriveWithCompletionHandler:]_block_invoke] : BRUploadAllFilesForLogOutOperation completed with error Error Domain=NSCocoaErrorDomain Code=3072 "The operation was cancelled."
iCloudPreferences   error   15:45:58.015652 -0800   com.apple.preferences.icloud.remoteservice  [AOSAccounts] : [-[MMMobileDocumentsService handleOperationCompletion:]] : BRUploadAllFilesForLogOutOperation  or BRDownloadAllFilesForLogOutOperation completed with error Error Domain=NSCocoaErrorDomain Code=3072 "The operation was cancelled."
iCloudPreferences   error   15:45:58.016112 -0800   com.apple.preferences.icloud.remoteservice  [AOSAccounts] : [-[MMMobileDocumentsService handleOperationCompletion:]] : BRUploadAllFilesForLogOutOperation  or BRDownloadAllFilesForLogOutOperation failed with error Error Domain=NSCocoaErrorDomain Code=3072 "The operation was cancelled."
iCloudPreferences   error   15:45:58.029026 -0800   com.apple.preferences.icloud.remoteservice  [AOSAccounts] : SetEnabledOnACAccount_block_invoke Dataclass Action sent to save account robertbryanharrison@mac.com  service com.apple.Dataclass.Ubiquity enableState 0 : {
    "com.apple.Dataclass.Ubiquity" = ACDataclassActionMergeLocalDataIntoSyncData;
}
iCloudPreferences   error   15:47:05.448533 -0800   com.apple.preferences.icloud.remoteservice  [AOSAccounts] :  [GetProperty]  kMMPropertyMobileDocumentsMigrationStatusKey status: <CFBasicHash 0x61000066b300 [0x7fff99f38980]>{type = mutable dict, count = 3,
entries =>
0 : status = SUCCEEDED
3 : id = <CFString 0x61000046d540 [0x7fff99f38980]>{contents = "edac53f1-93db-48ac-b9f3-2512550632a7"}
11 : name = <CFString 0x610000233440 [0x7fff99f38980]>{contents = "NOT_NEEDED"}
}
  • I had a similar issue on a brand new MacBook Pro 2020. After reformatting, signing in and out, using the suggestions above I've had to escalate to Apple support. They said it might be a provisioning issue and to wait overnight to see if it changes. – Nikesh Oct 25 '20 at 20:37
  • Nikesh, did it help? On brand new MacBook Pro 2020 with M1 chip I migrated data from my older macbook and I noticed that iCloud is not available and none of the files were synced. – Anton Zorin Dec 10 '20 at 12:47
49

I had the same problem. I tried restarting, new user profiles, signing in and out of iCloud, check and unchecking documents in the cloud etc.

Each time I waited several hours, but my iCloud documents did not appear.

What finally worked was Dwight McKay's suggestion:

In the Mac Terminal program (in the Utilities folder), type:

killall bird
cd ~/Library/Application\ Support
mv CloudDocs CloudDocsOld

NOTE: the original instructions required deleting CloudDocs (rm -rf CloudDocs instead of mv). An edit was suggested to move rather than delete the folder, but this has not been tested. If you can confirm that this still works, please leave a comment and I'll remove this note.

If everything goes well, then you can delete the CloudDocsOld folder afterwards in Terminal:

cd ~/Library/Application\ Support
rm -rf CloudDocsOld

If something goes wrong you can recover the CloudDocsOld folder:

cd ~/Library/Application\ Support
rm -rf CloudDocs
mv CloudDocsOld CloudDocs

cd = change directory to...
rm = remove
-rf = recursive & force deletion of read-only files
mv = move and rename A to B


I had to wait about an hour for file names to show up, and of course the actual files are still in the cloud.

It is too technical for me but you can paste the following line into the Terminal to follow sync progress

brctl log -w

It took about 4 hours to go through 300 gb. brctl stopped output when it was done. If everything worked, you can then delete the CloudDocsOld folder from ~/Library/Application\ Support.

You can find more information at Dwight's page:

  • bird is the daemon that syncs iCloud documents

  • ~/Library/Application Support/CloudDocs contains the iCloud meta-data store

  • 1
    Yes, type enter after each line. The second line can also be written cd ~/Library/"Application Support" (the \ makes sure that the following space & Support are included in the directory name). It might work to do all this in the Finder: cmd-shift-g then "~/Library/Application Support" then drag CloudDocs to the trash. Then open the trash and control-click on CloudDocs and delete immediately. If you can't find CloudDocs at all, can you tell me what version of Mac OS you are on? (Apple Menu › About This Mac). – Andrew Swift Sep 13 '18 at 7:57
  • 3
    Related to the question by @ChrisKuo. A general word of caution would probably be in place here. rm -rf is a powerful command that can do a lot of harm on your computer. Please make sure you know what you are doing. Generally it is not advisable to copy&paste commands from websites. – n1000 Mar 8 '19 at 13:48
  • 2
    After doing a fresh Catalina installation, I had the exact same problem. I don't know if this technique resolved my issue because even after applying it, my files were still missing and appeared randomly couple of hours later. – Can Sürmeli Oct 9 '19 at 9:06
  • 1
    I had the same problem after a Catalina installation and migration. I had errors in Console for mdworker "System Policy: deny(1) on the Mail Library.". I had to remove iBooksAuthor.mdimporter from Library/Spotlight and then follow the steps described in this answer. – intagli Nov 12 '19 at 16:47
  • 1
    A safer alternative to rm -rf CloudDocs is to just rename it mv CloudDocs CloudDocsOld, then do the reboot. A fresh one should get created, then you can delete the old one after verifying the sync completed. – Taylor Edmiston Sep 6 '20 at 21:50
7

After months dealing with this issue I finally have a fix that makes sense. It's possible to create filenames with emojis on an iOS device that iCloud Drive on Mac doesn't know how to handle. If iCloud Drive is syncing across your iOS devices but not macs, try this:

On an iOS device, rename or delete suspicious filenames to remove emojis and weird unicode characters.

In my case I went nuclear and tried to delete them all from my iPad (after backing them up by copying them to On My iPad). Here's the problem with that, they're still in Recently Deleted and Macs still don't like it. You need to navigate to Locations -> Recently Deleted and tap Select and then Delete All at the bottom.

Afterwards do the sacred ritual we've all done tens of times:

  • Disable iCloud Drive in Preferences -> iCloud
  • In a terminal killall bird; rm -rf ~/Library/Application\ Support/CloudDocs; rm -rf ~/Library/Caches/com.apple.bird
  • Reboot the computer
  • Enable iCloud Drive in Preferences
  • Cry real tears of joy
  • 2
    Warning: make a copy of your files before doing this. ~/Library/Caches/com.apple.bird may store files that you have modified that aren't in sync with iCloud Drive and which don't exist anywhere else. If you follow these steps because of a sync issue without making a copy of your local changes first, data loss may result. – bjb568 Sep 19 '19 at 17:30
  • I have no issues as far as I can tell with "unicode characters", so I'm not sure why you assume this is part of any problem, @Christopher Camps. macOS fully supports Unicode since ages. – MiB Jul 22 '20 at 9:52
  • I'm almost 100% certain you don't know what unicode is. Unicode is a standard for encoding characters. macOS has used unicode since OSX to encode file names. This means that all characters are encoded using unicode. However, even if macOS didn't use unicode, your comment still doesn't make sense. This is because all of the characters would simply be encoded using a different standard. – Peter Schorn Sep 15 '20 at 1:27
  • @PeterSchorn thanks for your incredibly thoughtful and helpful comment. Obviously I meant uncommon unicode characters that ios has no problem creating but that are causing some other part of the sync system to break. 🦧 – Christopher Camps Oct 29 '20 at 19:19
  • @ChristopherCamps Well, then you should've said that because it was not obvious to me, and other people commenting on your answer didn't seem to arrive at that interpretation either. – Peter Schorn Oct 30 '20 at 1:49
5

I wrote a script. Uses sudo... so use CAUTION!

#!/bin/bash

if [[ $EUID -eq 0 ]]; then
    echo "Killing bird."
    killall bird
    echo "Removing CloudDocs"
    cd ~/Library/Application\ Support
    rm -rf CloudDocs
    echo "Immediately rebooting!"
    shutdown -r now
else
    echo "
    This script needs run as sudo. 
    Use CAUTION when doing so.
    You accept full responsibility using this script.
    You should know what it's doing BEFORE you run it.
    "
fi

Restarts automatically immediately after.

  • 1
    Great! However, I only need the first line in most cases to fix this. So can be overkill. – MiB Jul 22 '20 at 9:54
  • 2
    Adding another +1 that here on Catalina I only needed to killall bird for iCloud to immediately begin syncing the directory structure and files. – Jake Bathman Sep 29 '20 at 19:14
1

Thank you. My solution proved a bit different, and as I don't fully understand it, I didn't post it.

My problem related to the system in question's multiple network interfaces - specifically, two active ethernet connections. A combination of deleting/recreating the interfaces and the update to macOS 10.13.2 left iCloud functioning correctly, but as I said, I don't really know why. I'm only clear that some problem with multiple network connections was at the root of it.

1

I had a similar issue to Brian's below -- earlier in the day I had been using iPhone USB for my network, and when I switched to Wifi later on, iCloud would not sync. I turned on my VPN and it started syncing instantly. Switching network connections seems to create the problem but also resolve it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .