3

I am usually backing all apps which I purchase. Recently I purchased a bunch of new apps, which I would like to download. So I opened the iTunes (12.6.20) switched to purchases and right now I see that cloud icon for downloading the app in some apps is missing. See picture.

Do you know what is causing this problem? I would like to download all my purchased apps. Sign off/on doesn`t solve the problem.

Thanks for the help.

Some facts:

  • My local apps library is completely empty, so nothing is downloaded yet.
  • I am currently using 12.6.3.6 iTunes
  • If somebody else will sign into same iTunes on the same computer as I do he is able to download all apps
  • I am a family organizer for family sharing
  • I tried to sign on different computers to iTunes and the apps which I can download where all same.
  • The solution that I can download the app by searching this app on iTunes doesn`t help because I would like to download a purchased app which is currently not available. (Yes It can be, My brother has the same app purchased which is not available yet but through purchases, list can be downloaded)

enter image description here

  • the cloud icon is usually just updates or something that didn't transfer to your Mac. – bret7600 Jan 26 '18 at 18:16
  • Ok so is there a way to download a app from purchases? Because I have nothing in local apps library in iTunes. – Bjørson Ålmer Jan 26 '18 at 18:18
  • For example I have in purchases app which is not available in AppStore but I would like to download it. – Bjørson Ålmer Jan 26 '18 at 18:21
  • Maybe try 12.6.3 - support.apple.com/en-gb/HT208079 – Tetsujin Jan 27 '18 at 7:19
  • @Tetsujin nope, no changes. I tried also on different comupters and still only the same apps are available to download – Bjørson Ålmer Jan 27 '18 at 13:43
1

Hi I would try downloading the apps onto your device with whoever a sign in shows all of them in there library and then log out of there sign in and sign back into your name and see if that helps I had a similar issue in the past and this seemed to solve the problem

0

Make sure that you authorize iTunes with your Apple ID account. When you authorize your Mac or PC, you give it permission to access your apps, audiobooks, books, music, movies, and other content.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    yes, account is authorized, if not I will be unable to download all apps. But I can download some of them, but not all of them. Thats the problem – Bjørson Ålmer Feb 9 '18 at 21:58
  • Check for an iTunes update. If yours is up to day (I think 12.7 is out) then call Apple Support. This appears to be an issue with iTunes. – Melvin Jefferson Feb 9 '18 at 22:35
  • Ok, i have the last official itunes which supports apps downloading. – Bjørson Ålmer Feb 12 '18 at 12:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .