3

I'm having issues with FileVault being stuck while encrypting, and it's causing major slow downs in my system.

I initially had my file system set to case-sensitive, which prevented me from installing Photoshop, so I created a TimeMachine backup, and converted that backup to case-insensitive and then restored my computer using that backup.

The system came back online with no issues, everything was running perfectly. Then I turned on FileVault, and that's when the problem started. FileVault took a very long time (as in days) and now has become stuck at 37% for the past several days. It seems like it is doing something though, because my system is pretty slow, and I feel like it's because FileVault is causing high disk IO.

I tried rebooting into recovery mode to try to disable volume encryption, but that didn't work, because an encryption was still in progress. I then tried to create another TimeMachine backup of the current system so I can restore it, but that won't backup because an encryption is still in progress.

I'm not sure what to do at this point, and any help is appreciated. Below is the output of diskutil apfs list:

$ diskutil apfs list
APFS Container (1 found)
|
+-- Container disk1 B6E6727F-F976-4C61-8573-342837F7C5A7
    ====================================================
    APFS Container Reference:     disk1
    Capacity Ceiling (Size):      479894224896 B (479.9 GB)
    Capacity In Use By Volumes:   326560948224 B (326.6 GB) (68.0% used)
    Capacity Available:           153333276672 B (153.3 GB) (32.0% free)
    |
    +-< Physical Store disk0s2 AE5D924D-64EC-4D26-AE25-3B5D1C8CE77E
    |   -----------------------------------------------------------
    |   APFS Physical Store Disk:   disk0s2
    |   Size:                       479894224896 B (479.9 GB)
    |
    +-> Volume disk1s1 4ED72370-8A66-4C55-B712-9D4B3D8F133C
    |   ---------------------------------------------------
    |   APFS Volume Disk (Role):   disk1s1 (No specific role)
    |   Name:                      OWC Aura 2012 (Case-insensitive)
    |   Mount Point:               /
    |   Capacity Consumed:         323197358080 B (323.2 GB)
    |   Encryption Progress:       37.0% (Unlocked)
    |
    +-> Volume disk1s2 5C238A3E-E8E3-4060-B9BA-EE79508C0697
    |   ---------------------------------------------------
    |   APFS Volume Disk (Role):   disk1s2 (Preboot)
    |   Name:                      Preboot (Case-insensitive)
    |   Mount Point:               Not Mounted
    |   Capacity Consumed:         40062976 B (40.1 MB)
    |   FileVault:                 No
    |
    +-> Volume disk1s3 5EEC818B-E725-44F3-9D97-AD53518AFB23
    |   ---------------------------------------------------
    |   APFS Volume Disk (Role):   disk1s3 (Recovery)
    |   Name:                      Recovery (Case-insensitive)
    |   Mount Point:               Not Mounted
    |   Capacity Consumed:         1016365056 B (1.0 GB)
    |   FileVault:                 No
    |
    +-> Volume disk1s4 B89AC935-5914-4BD7-AE25-41C75AB913FD
        ---------------------------------------------------
        APFS Volume Disk (Role):   disk1s4 (VM)
        Name:                      VM (Case-insensitive)
        Mount Point:               /private/var/vm
        Capacity Consumed:         2147504128 B (2.1 GB)
        FileVault:                 No

I also tried running diskutil verifyVolume /dev/disk1s1, and I get the following warning repeated about 30 times:

...
Checking the fsroot tree
warning: fs_val: object (oid 0x2db7b3): invalid crypto_id (0x4)
...

System info:

macOS High Sierra (Version 10.13.3)
MacBook Air (13-inch, Mid 2012)



Update: 2018-01-26 12:12

Not sure if this is relevant information, but I feel like my file system is not updating the amount of free space it has. I just did some cleaning up, and deleted over 50 GB of data from my computer, but the amount of free space show in the Finder status bar, and df command hasn't changed.

I have a feeling this is related to the problem with FileVault, since the file system is not able to calculate what it has in.


Update: 2018-01-26 12:21

Now after about 15 minutes later, Finder status bar is reflecting the correct amount of free space, but df is still showing the wrong one.


Update: 2018-01-27 07:05

And now for some reason it looks like there is movement. Suddenly overnight progress has jumped from 37% to 44% after days of not doing anything.

  • did you manage to resolve this issue? I am stuck at the exact same situation.. – Angel Nikolov Dec 5 '18 at 23:43

You must log in to answer this question.

Browse other questions tagged .