8

Apple messages keeps asking for password every time I try to log in to my jabber account.

The password is correctly saved in the keychain (in fact I just go and copy it from there each time). Save Password to Keychain is of course always checked.

I can not find Keychain First Aid in High Sierra, it seems it has been removed. I tried creating a new login keyring, removing the jabber account and re-adding it (both from Messages and from System Preferences). I also tried adding imagent and Messages.app to the authorized applications list for that Keychain entry (as suggested here).

The only weird thing I encountered is that when the problem started I had two entries in keychain for that password. Now I only have one, no matter what I do.

I also tried resetting messages by renaming away ~/Library/Messages but this led to a "message database is upgrading, please try again later" prompt.

It seems that while creating a new account saves the password in the keychain as it should, Messages fails to read it.

11

This solution worked for me: https://discussions.apple.com/message/32744059#32744059

After running a comparison with a working version (on Sierra 10.12.6) it looks like the solution (at least for me) is to change the Where value that gets generated on sign in from what gets populated when adding an account in High Sierra com.apple.account.jabber.password to Jabber

In order to make this change follow these steps:

  1. Open Keychain Access
  2. Search for com.apple.account.jabber.password
  3. Double click it to open the attributes prompt
  4. In the Where field (fourth one down) you should see com.apple.account.jabber.password
  5. Replace all text in that field with Jabber
  6. Click Save Changes

After making this change the first launch of messages asked me to allow permission to access keychain. After doing so any subsequent open of messages works as expected.

  • I had the same problem and changed the where in keychain to jabber and the problem was solved... many thanks – Yassmine Oct 20 '18 at 20:30
3

I get the same error. Here is my fix

Open Keychain Access
Search for com.apple.account.jabber.password
Double click it to open the attributes prompt
In the "Account" field iMessage feed automatically "xxx.xxx@gmail.com@talk.google.com"
Replace all text in that field with only "xxx.xxx@gmail.com"
Click Save Changes

0

I had same problem repeatedly. When I looked into the Jabber keychain attributes, I selected "show password" and saw that the stored password was incorrect... a very old password that I had used on that account a few years ago. I manually updated it to use the current correct password, and now the problem seems to have disappeared. It seems that the password that I had been typing upon launching Messages app in wasn't being written to the keychain, so at least manually updating the password works around the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .