1

I'm facing multiple Boot/Update/Shutdown issues with my Mac Pro (2018)

1) Mac gets stuck on a black screen while shutting down (no cursor or UI elements visible)

2) Mac doesn't boot on it's system drive by default. Instead it goes for a "install" drive and gets stuck on "macOS could not be installed on your computer" (see image below). I'm forced to click the restart button and hold the alt key to be able to chose the appropriate drive and once then boot the OS.

3) From within the OS, Mac keeps warning me that an update is available. I already tried to install it many times but every time the mac restarts in consequence of the update it get's stuck in a black screen for something like 5 min, then I noticed a progress bar that showed up saying that the system is installing the update (2min) and finally, suddenly, it goes back to black and stays there for a long period of time.

I don't get any visual feedback of what's going on I stopped the system by pressing and holding the power button after 10 minutes of black screen.

Powering it back on while pressing the alt key (yes, I need to do this every time I boot the mac in order to avoid the error mentioned in line 2!) and choosing the system drive takes me back to the operating system.

If I open the "App Store" application I will see that the update is still there and to install it I'm forced to download and install it once again.

What's is going on? Am I missing something?

enter image description here enter image description here

  • Also note that: 1) A Mac Pro has not been released since 2013 and 2) Apple has released no new products yet in 2018. If you ARE working on a 2018 Mac Pro (meaning you’re working on unannounced Apple hardware) you may be violating Apple policies by posting about it. – NoahL Jan 26 '18 at 13:39
  • I didn't say the mac was manufactured in 2018. When I mentioned 2018 means I was saying it purchase date. – Lothre1 Jan 26 '18 at 13:49
  • ok. Because it’s possible that Apple will release a new product in any given year, the general site standard is to use model year dates instead of purchase years. That said, this is a very descriptive and well worded question, and welcome to Ask Different :) – NoahL Jan 26 '18 at 13:57
1

Possibly a Combo Update could remedy the situation, as your Mac seems to not like the update, or it could be lying to itself about having which prerequisites are required, or more likely, the package appears to be either unsigned or un-executable.

The Combo Update for macOS 10.13.4 is available from Apple at This Link

0

Just had a similar problem and added a solution which worked for me to this question.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .