46

Recent versions of StuffIt will extract .xz archives, but they will not run on Mac OS X 10.4 Tiger. And using something like Fink, it should be possible to install xz-utils on 10.4, so that .xz archives can be extracted from the Terminal.

But is there any graphical application that will run on Mac OS X 10.4 Tiger, and which will extract .xz files?

It's OK if this application supports extracting .tar.xz archives in a single step, but not necessary, because if it extracts the .tar.xz file to a .tar file, even an older version of StuffIt can extract that.

38

I'd give The Unarchiver a try. It's free, graphical, supports 10.4 and can extract .xz archives.

  • 2
    The Unarchiver is superb. It's my utility of choice even on Lion. – TJ Luoma Dec 18 '11 at 18:03
  • It's also available in the Mac App Store, as noted on the linked page. – Caleb Huitt - cjhuitt Mar 23 '13 at 15:11
  • 3
    3 years later - I just found this answer and used it on an .xz file in Mavericks. Still works like a charm. – hairboat Aug 28 '14 at 23:52
  • 2
    Good on Sierra. – HenryRootTwo Apr 1 '17 at 2:49
73

Not graphically, but this showed up in searches so for those of us who want to do it from the command line using Homebrew:

$ brew install xz
$ xz -d to-extract.xz
  • 3
    or via macports: sudo port install xz – Andy Barbour Jul 8 '15 at 19:02
  • Well done - this worked for me to prepare the debian armhf software for my beagle bone black using xz and then dd to dump the disk image to the micro SD card. +1 – bmike Jan 23 '16 at 1:42
41

I've used the following native command on mac:

gunzip filename.xz 

it works fine!

  • gunzip is only used for .gz files. – raimue Nov 8 '16 at 0:56
  • 10
    Obviously untrue given the answer above. – David Braun Dec 21 '16 at 23:27
  • 10
    On a Sierra system gunzip can definitely decompress XZ files out the box. macOS uses the BSD variant of gzip linked against liblzma, which gives it support for that file format. – mjturner Apr 5 '17 at 20:21
  • 1
    I confirm that gunzip filename.xz does not work in Mac OS X 10.4. – kernigh Jun 22 '18 at 18:27
  • 1
    I find it works for me; I am using High Sierra. – James Douglas Sep 12 '18 at 9:40
4

The tar -xzf command didn't work for me, but I installed XZ utils http://macpkg.sourceforge.net/ and then unxz filename.tar.xz. Then you can just use the command tar xf filename.tar to open the tarball. I have OSX Mountain Lion (version 10.8.5).

  • The reason is that the option -z specifies gzip compression/decompression. The right option for xz is -J. But in fact, modern tar implementations do not require you to specify the decompression algorithm. Just tar -xf is fine. – Siyuan Ren Oct 18 '14 at 8:57
2

On a mac, you can open up the terminal and use the command tar -xzf filename.xz if you're not looking to download a new App just for .xz archives

  • 3
    Are you sure about that exact command? The z flag for tar tells it an is archive gzip-compressed. On systems where tar supports xz, the J flag is typically used for that. Or to extract it can simply be omitted; if tar supports a compression method will usually automatically identify it. But back when I asked this question, I had tried command-line tar on a .tar.xz archive and it hadn't worked. Assuming it does now, do you know what version of OS X added it? Back when I asked this question, OS X didn't (seem to) ship with xz-utils: i.e., no xz, unxz, and no xz handling in tar. – Eliah Kagan Oct 8 '14 at 15:12
  • 1
    works for .tar.xz too – Sergei Sep 29 '17 at 13:24
  • 1
    tar -xf is the correct command. – gabeio May 7 '18 at 14:49
2

MacOS 10.9 and later natively support xz (but the Finder works only on tar.xz files) according to a comment in reply to the similar excellent question at Can MacOSX 10.7 open tar.lzma files

My tests show the MacOS 10.11 Finder fails to graphically decompress plain xz files unless they contain tar format. MacOS 10.10 suffers the same bug according to the article at https://www.ctrl.blog/entry/archive-utility-xz

however the command line programs gunzip, gzcat and zcat automagically hack all xz files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .