Not sure about the Yosemite version because "About this mac" option doesn't work too. Terminal, X11, Screenshot to name a few, don't work.

Used to work fine since I updated from Lion a few months ago.

This message shows up in "console" when I try to open one of those options:

23/1/18 21:36:52,032 com.apple.xpc.launchd[1]: (com.apple.Terminal.11392[853]) Service exited with abnormal code: 1

I found this answer from 2014:

You installed another version of bash,right? The default login shell is /bin/bash. you can change it following these steps,

go to "System Preferences" > "Users & Groups" click the "padlock" icon and authenticate right-click the icon for your user and select "Advanced Options..." change the value for "Login shell"

My default login shell is "/bin/bash" so I assume that this user didn't had the same problem after update to Yosemite.

At this point I'm completely lost with my poor knowledge on IT...

Thanks in advance!

  • Welcome to Ask Different! :) It seems to me that you're having some broader issues, not just with Terminal. Is that correct, or am I misreading your question? If so, perhaps your Terminal problem is actually part of a broader issue. Can you explain what happens when you try to access About this Mac and when you try to take a screenshot?
    – Monomeeth
    Commented Jan 23, 2018 at 22:20
  • Hi Monomeeth! First, thanks for your answer! When I try to run "About this mac", "Terminal", "Midi & Audio Settings", "screenshot app" and many others just don't open. I've tried to restore disk permissions but still don't work. As I said, everything used to work fine but I don't know if I could delete something today that causes this. I think I'll have to back up everything and reinstall OSX again... Commented Jan 23, 2018 at 22:30
  • Ok, so do you mean absolutely nothing happens? Or do you get an error message? Maybe a spinning beach ball cursor for a few seconds? Anything at all?
    – Monomeeth
    Commented Jan 23, 2018 at 22:33
  • Anything at all. Commented Jan 23, 2018 at 22:34

1 Answer 1


Troubleshooting is a process of elimination and often requires some patience. In your case the best option may be to just reinstall macOS, but before doing that there's a few things we can try.

The first thing I'd probably do is start your Mac in Safe Mode and test to see if you can use your system

Boot into Safe Mode

Follow these steps to boot your Mac into Safe Mode:

  1. Fully shut down your Mac
  2. Restart your Mac
  3. Immediately press the Shift key and keep it down
  4. Let go of the Shift key when you see the login window (NOTE: If you have FileVault enabled you may need to log in twice).
  5. Take a note of what happens (i.e. can you launch Terminal, view About this Mac, etc)
  6. Exit Safe Mode by restarting your Mac as normal
  7. Again, take a note of what happens (i.e. can you launch Terminal, view About this Mac, etc)

Once you've booted into Safe Mode, let me know how you went and we'll go from there. Primarily we need to establish if everything works okay in Safe Mode or not, and whether things get back to normal afterwards.

  • Just tried with Safe Mode and don't work. I've noticed that Safari, Calendar and other native apps don't work too. Maybe it gives you more information about what is going on. Thanks again!! Commented Jan 23, 2018 at 23:32
  • Can you let me know the exact model of Mac you have? Also, can you clarify if it's only native apps that aren't working (i.e. do 3rd party apps still work fine)?
    – Monomeeth
    Commented Jan 24, 2018 at 1:25
  • iMac late 2009 Intel Core 2 Duo. Third party apps work fine. Commented Jan 24, 2018 at 10:34
  • 1
    Finally I decided to update to El Capitán and everything work fine atm. Commented Jan 25, 2018 at 15:18
  • 1
    Assuming you have enough RAM I think you'll find that El Capitan works just fine on your model iMac. It's a rock solid stable version of macOS and unless you had some major software incompatibility I wouldn't go back. That said, I did some research into your issue and this was something that inflicted a lot of users. They would upgrade to Yosemite and everything would be fine, but that an app would require installation of Java or an installation Flash Player and this would cause a conflict with native apps. If you decide to go back to Yosemite, let me know and I'll send you some links.
    – Monomeeth
    Commented Jan 25, 2018 at 23:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .