3

Whenever I lock my screen (using command+control+Q), the display goes to sleep within about 5 seconds. How can I prevent this?

This happens while plugged in, and my screen is set to never go to sleep while on power:

enter image description here

Even if I wasn't plugged in, on battery life, the screen should go to sleep within 2 minutes, not 5 seconds:

enter image description here

I'm on High Sierra 10.13.2.

edit: I gave up on locking with cmd+ctrl+q and just went with enabling my screen saver and setting the system to require a password on screen saver wake.

  • Do you have a blank screen saver set to come on after a short amount of time? – jmh Jan 23 '18 at 0:53
  • @jmh Nope, my screen saver is set to come on "Never" (and it's not blank at any rate). – Alec Jan 23 '18 at 1:23
4

Alec,

You're running up against built-in functionality: once the "unlock" screen appears and you don't enter your password, macOS falls back on the screen saver, or (without a screen saver) goes off. Or, as you've noticed, when you use cmd+ctrl+q, it just goes to sleep, screen saver or no. There's no control to change that behavior in the OS.

However, there are some free utilities on the Internet and the App store (Caffeine and Anti Sleep come to mind, but there are others) which disable the display sleep and/or the system sleep. I gave Anti Sleep a try with the keyboard shortcut, and it did just what you're looking to accomplish: it kept the screen "awake" after it was locked.

Edit: It looks like cmd+ctrl+q and Anti-Sleep's first option, "Prevent System Sleep when lid is closed" don't play together too well. Uncheck that option to make this work.

All that said, be aware that the sleep feature is built-in to reduce power consumption and extend the life of your display. By leaving the screen powered on all the time, you negate these protections.

  • Anti Sleep unfortunately seemed to do nothing for me. Installed, restarted, all "Prevent" options are checked, Prevent Sleep Timeout set to Indefinitely (also tried 72 hours), screen still goes to sleep within 5 seconds of cmd+ctrl+q. Same story with Caffeine. – Alec Jan 23 '18 at 15:59
  • Uncheck the first line:"Prevent System Sleep when lid is closed". That worked for me. – le_jawa Jan 23 '18 at 16:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .