1

This is my first post in these forums, so please bear with me if my question is poorly phrased. I'm trying to install macOS and iTunes updates via the app store, and come across a screen like this (normal): enter image description here

Nothing to worry about, right? Then I click "Update All" like I usually do, and it just turns gray, and the other 2 things inside don't become gray: enter image description here

I then click on the individual "Update" buttons and they gray out similarly: enter image description here

It just stays like this - I've tried leaving it for days even, and it just doesn't work.

Anyone ever face this issue before and know how to fix it? Thanks!

  • Just to make sure, is your system clock set correctly? – Jake3231 Apr 29 '18 at 13:03
1

Muhammed, I've seen the first part of that behavior before with updates, and while not exactly intuitive, it is normal. macOS is typically downloading and installing in the background, and the update screen won't respond until that is done.

However, you said you left it running for days. That doesn't sound so normal. I'm going to presume you have some sort of high-speed Internet connection (at least 10Mb/sec), and if that's the case, it's probably not your Internet connection.

However, If you want to see the progress of the download (if there's one going at all), look at the "LaunchPad" icon on your Dock. It will display progress bar below it when something is downloading and installing.

LaunchPad icon with progress bar

If there really is nothing happening, try logging out of the App Store and back in. To do this:

  1. Open the App Store
  2. Click on the Store menu
  3. Click "Sign Out"
  4. On the Store menu again, click "Sign In..." and sign back in

Sign out

enter image description here

That will probably do it for you, but give it a try and see.

  • Thank you for your answer, @le_jawa! Unfortunately, this didn't work either. I've tried quitting the app store and restarting the computer, each to no avail – Muhammad Khan Jan 23 '18 at 21:29
  • @MuhammadKhan - 10.13.3 was just released today; does that show up on your update list now? If so, can you try the update again and see if it works better this time? One note on that - everybody's trying to download it right now, so it may be slow. – le_jawa Jan 23 '18 at 21:35
  • Yes it does show up on the update list, but the same stuff is happening. Debating whether going to an Apple store and having a "genius" take a look – Muhammad Khan Jan 24 '18 at 3:07
  • If you're feeling daring, you can open the Console and look at /var/log/install.log. It's almost certain to have the error, but the file is long and tedious. – le_jawa Jan 24 '18 at 3:57
  • You're right, it's very long! Do you know keywords I'd exactly be looking for? – Muhammad Khan Jan 24 '18 at 4:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .