2

I have a Drobo network file server which insists on offering it's mounts via both afp:// and smb://. Is there any way to force my Macs (they are all running High Sierra) to NEVER mount network volumes via AFP?

There is no way in the Drobo administration to disable AFP. I've talked Drobo Support: it's a "feature we're considering."

To be clear: I understand how to mount it via SMB. There are certain situations (that I seem to be unable to control) where the macs sometimes automount via AFP. I think it might have to do with remembered "open recent" files -- but I'm guessing. So I want to break/disable AFP entirely. I'll take a failure to mount, instead of the problems I get when it automounts with AFP. (files don't save, apps and the finder lock up, etc)

  • 1
    Check to see if you have any Keychain entries for the Drobo server that specifies the afp protocol: [yourdroboname]._afpovertcp._tcp.local. . If so, delete them and see what happens. If this is the solution, perhaps it may then be possible to programmatically (through a script or something) delete these afp keychain entries on user login/logout, just to keep things clean. – IconDaemon Jan 22 '18 at 22:41
2

Two options that may be helpful in your case:

• Close access to TCP port 548 - that should disallow any AFP access.

• Volumes formatted as APFS can't offer share points over the network using AFP. (see https://support.apple.com/en-us/HT208018)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .