1

I have my contacts stored on iCloud, so they sync between my iPhone and my MacBook Pro. On my iPhone, the Messages app displays the Contact Name, however on my MacBook Pro it does not. It just displays the telephone number (including country code).

Strangely, if I go into contacts and manually edit the number so that it is the country code (e.g. +44, rather just '0'), it then displays correctly with the name. However, ideally I would like not to have to edit all of my contact numbers to include the country code. Another strange behaviour is that for contacts where I have their photo, it displays the photo next to their telephone number, so it is recognising the number as belonging to that particular contact, it is just now showing the contact name.

This issue has only occurred recently after I signed out of iCloud on my MacBook Pro and then signed back in.

Does anyone know how I might be able to resolve this?

Kind regards, Russell

1

The problem seems to be that the phone numbers in your contacts have lost the proper format. They should be in the form (123) 456-7890 and they have been formatted as 1234567890. It seems that iOS does a really literal comparison and it can't resolve this difference.

I fixed this on my iPhone 5s running iOS 12 by changing my region from the US to Canada. That evidently forces a re-formatting of the erroneous numbers. Then I changed it back to the US. Note that my contacts were synced with Google/Gmail. I think this should also work for iCloud, but your mileage may vary.

Go to Settings app → General → Language & Region → Region, tap on Canada, then tap Done. (I bet selecting any different region would work). The change takes a bit of a time. When it is complete, look at your recent calls, voicemails and messages - they should be displaying names. Look at your contacts - phone numbers should be correctly formatted. If so, the problem should be fixed. In any case, change the region back to United States.

  • nifty trick ...... – Ruskes Dec 26 '18 at 5:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .