I have a little over 9000 songs. Between yesterday and this morning, iTunes Match is finally done evaluating and uploading songs, and it seems to have made a few mistakes.

If I show the iCloud Status column in my song list, in a number of albums I'll see "Matched" for most of the tracks, but "Uploaded" for one or more track. If I look up that song/album/artist on the iTunes Store, Apple has those songs. I've even looked at the track info to see if they might have been encoded differently, but on the few I've spot checked they have the same encoding as the other songs in the album that were matched.

I've been able to force iTunes Match to re-evaluate songs that showed "Error" before (no errors now), but I can't seem to figure out how to force it to re-evaluate these songs that were non-matches even though they're in the store. How do we do this? Do I turn off iTunes Match and start over again? I've been reluctant to do so considering how long it took yesterday.

  • I am wondering the exact same thing. Nov 15, 2011 at 19:52
  • 1
    I think the best way to do this is to remove them from your iTunes library (keep the files and put them somewhere). Then restart iTunes and it should remove them from the cloud. When they're gone, re-add them. Hopefully iTunes Match will correctly identify them. Let me know if this works and I'll transfer it to an answer for others that may inquire about the same thing.
    – user10355
    Nov 16, 2011 at 4:51
  • I just tried this with a test track (I didn't want to lose metadata unnecessarily), and it didn't appear to work. iTunes Match did seem to "upload" it very, very quickly, so I'm wondering if the version previously uploaded did not get deleted from iCloud even though I checked the box to have it do so. I'm thinking more and more of just flipping Match off and then turning it back on again, maybe after letting it sit for a day or two.
    – beverson
    Nov 17, 2011 at 4:16
  • A question about what causes this (distinct from your question about how to fix it) has also been asked.
    – orome
    Nov 17, 2011 at 21:52

6 Answers 6


You may not be able to get complete matches, but here's what I have been doing in the cases where one or two tracks don't match.

  1. Select the item(s) to attempt to re-match.
  2. Right-click on them, and select "Create AAC Version"
  3. When this is complete, hit alt-backspace, and choose to remove both the original and the iCloud version. Also choose to delete the items from disk.
  4. Go to the "Store" -> "Update iTunes Match" menu item.

Note that this will keep the play counts, etc on your tracks. It may not succeed on every track, and sometimes repeating the process picks up another track.

Occasionally, I'll get a "Removed" icon there after doing this: just right-click and choose "Add to iCloud" on these.

  • Sounds promising. Tried it with one track to test it out, and iCloud Status is sitting on "Waiting" for that track. I'll post again when it changes.
    – beverson
    Dec 20, 2011 at 14:49
  • Yeah, I found sometimes they stick on Waiting for a while, then change to either Uploaded (bah) or Matched (woohoo). Dec 20, 2011 at 23:48
  • I'd like to confirm that this works. Here are a few comments that might help: Step 3: Be sure the newly created files show up as Duplicates and then option-delete the original files Step 4: (Newer versions of iTunes) File → Library → Update iCloud Music Library
    – Ross
    Apr 22, 2016 at 19:21

The least destructive approach I've found is to:

  1. On an iOS device, force- or long-press on the song in question in the Music app, and select Delete from Library.
  2. On the Mac, wait for the iCloud Status to change to Removed.
  3. On the Mac, right click the track and choose Add to iCloud Music Library.

Doing it this way ensures that the song is never removed from your iTunes database, just from the iCloud Music Library.

Unfortunately, I haven't found a way to force the removal from iCloud Music Library within iTunes, without also deleting song from the local iTunes database. Maybe it would be possible with a second iTunes library that doesn't have the songs locally…

I originally scanned my library when iTunes Match was first released, and re-adding the Uploaded tracks now is yielding about a 30% Matching rate, with 70% just becoming Uploaded again.

This approach is working for me as of iTunes (on macOS 10.14.6) and iOS 13.2.3.


When you view your library from the web interface of Apple Music, you can directly remove items from your iCloud Music library, without affecting the files on your local database.

Deleting an album from Apple Music for Web

After deleting the items, make sure to "Update Cloud Library", and check they are "Removed" Re-adding a song to iCloud Music library


Try deleting the "uploaded" ones from the service & run Match again to see if it does better the second time around.

  • 1
    Removing any track on the cloud will also remove the track from all devices. This would also remove the original from the computer. Clouds sync changes in both directions. Aug 7, 2019 at 13:46

Worth a try: change the tracks "Kind" to something else than music and then change back?

(not able to test myself unfortunately)

  • I didn't check all of them, but I spot-checked about 50 tracks or so. They all have "Media Kind" selected to "Music" and then grayed out so I can't change it.
    – beverson
    Nov 21, 2011 at 13:39

Select and right click one track or multiple tracks and select "Check Selection". Worked like a charm for the albums I had uploaded by CD.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .