I use the command-ctrl-Q key in emacs, but find that it is locking my screen on Mac OS X High Sierra. Checking the System Preferences in the Keyboard Shortcuts finds nothing to turn off.

I'd rather not move my meta key off of Command to option and thus keep it where I'm used to it.

How can I disable this functionality?

up vote 3 down vote accepted

The following worked for me:

Open "System Preferences", select "Keyboard", then "Shortcuts".

From the list of shortcut categories in the left-hand list, select "App Shortcuts".

Add (this is counter-intuitive since you want to disable an existing shortcut) a new shortcut using the "+" button:

Under "Menu Title", enter "Lock Screen" (this should be how the action appears on the "Apple" desktop menu).

Then under Keyboard Shortcut, enter a key combination that you can "sacrifice". You could use something hard to type like Ctrl + Alt + Cmd + Shift + L.

You "save" the new Keyboard Shortcut (which actually overrides the previously invisible Ctrl + Cmd + Q shortcut) by closing the Keyboard preferences window.

Now you should be able to enjoy Ctrl + Cmd + Q's awesome Emacs binding again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.