The card I'm presented with when I use Apple Pay from my Mac is the wrong one. I've set the default card correctly in iOS (where it appears correctly), but when Apple Pay in invoked from macOS, even when payment is completed on iOS, the wrong card is presented on macOS.

How do I set the default card for Apple Pay on macOS?


This can happen when you have Apple Pay enabled on your Watch with a different payment option as the default there. There appears to be no way to configure the order in which devices are offered when more than one (Watch and iPhone, for example) are present, so that if Watch is present (unless Watch is disabled for Apple Pay entirely) it will "jump the queue" and offer whatever is the default there, independently of what you have set as your default on the iPhone.

To prevent this from happening and see your iOS-configured default card on macOS, disable Apple Pay on your watch (Watch > Wallet & Apple Pay, and remove all cards there, including Cash; turning off "Allow Payments on Mac" surprisingly doesn't do the trick).

| improve this answer | |
  • Great call posting this for others to search. TY – bmike Jul 23 '19 at 22:58

encouraged by the previous answer, but not wishing to go through deleting and re-adding my cards, i discovered also this: once i had matching settings on both phone and watch, there was nothing for my macOS device to be confused about. they are located in (Settings > Wallet & Apple Pay > Default Card) and (Watch app on phone > My Watch > Wallet & Apple Pay > Default Card) respectively.

| improve this answer | |
  • Bing. This is probably better as a stand alone answer as opposed to an edit above. – bmike Jul 23 '19 at 22:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .