0

Over the past couple days I have experience truly the most bizarre issue with an Apple product I have ever experienced. It has a somewhat long story to it, so I have all relevant details in chronological order.

First off, here's my specs: Macbook Pro Mid-2012 i5 w/ 250GB SSD, 1TB HDD in optical bay, 8GB RAM. Running high sierra 10.13.2

Alright. So, my computer installed some updates overnight last weekend. Worked fine the next day, except that Spotlight stopped indexing my applications folder. Rather annoying, but not completely bizzare. I tried fixing it by adding the applications folder to the Spotlight blacklist, then remove it. That did nothing.

Monday night, I tried the following three commands to try to force it to reindex my entire drive:

sudo mdutil -i on / 
sudo mdutil -i off / 
sudo mdutil -E / 

That did nothing immediately - again, unsurprisingly. But the next day, it still hadn't indexed the drive. The progress bar in Spotlight was stuck at the beginning.

Last night (Tuesday) was when the really bizzare stuff started happening. I tried to launch Fusion 360 (CAD software) from the dock, to be greeted with a "Fusion 360 cannot be opened because it is damaged or incomplete." I did the reasonable thing, and did a system reboot. I tried opening other software from the dock, but was greeted with the same message for all items in the dock. I then tried opening items from the launchpad, only to be greeted with no apps having icons whatsoever. Same thing with apps directly from my Applications folder - attempting to open any app, including system utilities like Terminal and Disk utility - resulted in the same damaged or incomplete error. Additionally, all the apps had their icons missing in the Applications folder. Right-clicking > show package content > browsing to the actual executable also does not work - it asks what software you would like to open the file with. I would have launched them from the terminal, but... well... I can't open it!

At this point, I got seriously freaked out about a corrupted drive, malware, etc, so I shut it down for the night. Today, I pulled the drive and took a full image of it for backup purposes. After some SMART analysis and the massive copy without any errors (used ddrescue on a linux box to clone the drive to an iso), I can say definitively that the SSD is not dying. After backing up the drive, I booted off a recovery USB drive and ran first aid on the main partition on the SSD, which found no errors.

I also tried other user accounts. First I tried another admin account, and google chrome launched on login fine, but no other software would open. After quitting google chrome, it refused to open again - same damaged or incomplete error. I then tried the guest account, where all the app icons on the dock are replaced with question marks. Again, nothing would open. However, I could open "About This Mac", and get a system report, etc. Clicking on software update results in a cryptic error about not being able to find the app to open that link with.

I also know that it isn't a broken SATA cable, as I've booted off a clone of the drive via USB and it has all the same issues.

At this point, I plan on doing a full OS reinstall and copying stuff back from my disk image. But if anyone has any idea why this happened in the first place, or what I could do to repair it short of doing a full reinstall, let me know. If you want screenshots of any of this weirdness (taken with a phone camera, because Preview can't open to take screenshots...) then let me know. Thank for any help!

  • Can you open the apps in Safe mode? Is the system date & time correct on the Mac? Try the remedy at this Apple discussion page to see if it works. It dates back to El Capitan, but it may apply to your situation. – IconDaemon Jan 18 '18 at 13:40
  • Update: it was a bad hard drive cable, which corrupted stuff in unpredictable ways. I had installed that cable myself a few months ago, and just contacted Amazon, who refunded me + $10 for fast shipping! – willem.hill Jan 18 '18 at 20:39
1

Following your initial description, I had the exact same problem. But it wasn't a malicious cable. So, for future reference and people with this problem, this is my solution, which is way more easier:

Let's assume you don't even have access to the terminal / console and therefore you have to boot into recovery mode:

  • (re-)boot into recovery mode (hold CMD + R until Apple logo appears)
  • start console / terminal
  • locate the folder /private/var/folders/ of your regular installation (!)

Heads up: If you are able to run the console within your regular installation, the folder is just there: /private/var/folders/. But if you use the recovery mode console, the /private/var/folders/ is the one of your recovery interface. You need to look for a folder like /Volumes/Macintosh/private/var/folders/ - that's the location of all your regular files.

If you get to the correct folder, you just delete it's content. (For security reasons you may move the content of this folder to a temporary location).

After your done, just reboot. This should fix your problem.

Nota bene:

As far as i know /private/var/folders/ just contains a lot of temporary files which will be deleted every time you restart your mac. If you are using the hibernation mode, this folder may grow constantly. It also could help to reboot the system while holding the SHIFT-key, as this also runs a few routines that will clear temporary files.

  • 1
    The solution worked for me, but at first I couldn't access my system volume - it's FileVault encrypted. I had to open DiskUtility, select the volume (grayed out), then click on "Mount". After that, it was accessible in Terminal. – karstenr Sep 18 '18 at 12:08
0

My wife's MacBook Air with macOS High Sierra developed a similar problem. No application could be launched, and even the icons in the dock didn't show up.

While other articles have suggested deleting everything in /private/var/folders except the zz folder, that was impossible in the normal account. Finder wouldn't delete anything, and Terminal couldn't be launched.

I ended up booting into recovery mode, using the Terminal and finding the /private/var/folders of the user account. When booting into recovery mode it will have a /private/var/folders associated with the recovery OS. From there I was able to rm -R each of the folders and their contents.

After doing that and re-booting normally the computer recovered. Some account credentials had to be re-entered, but overall the computer was working again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .