2

I'm a beginner at Linux OS's and thought I'd start learning. To do so I decided to install Ubuntu on a partition on my late 2013 15" mbpr, currently running mac os 10.13.

I followed this guide:

https://www.lifewire.com/dual-boot-linux-and-mac-os-4125733

and all was well until I realized I needed 16.04 not 17.10 (for ROS). In an attempt to re-install ubuntu I erased the partition I made for Ubuntu, but already at this stage the disk manager was showing strange things. The Ubuntu partition was grayed out, and when I removed that partition, my Macintosh HD partition ended up as an external drive.

I thought this could be solved by a reboot, but upon booting a broken GRUB interface turned up (I have rEFind installed as mentioned in the tutorial). I managed to re-install Ubuntu using the USB-stick I had prepared prior to my reboot but I can't seem to get access to my mac OS partition. To clarify, this was not an issue prior to fiddling around in the disk manager.

What I have tried so far:

  • Booting using the option key: Shows "Windows" (not bootable) and "Boot EFI" (Ubuntu).
  • Resetting NVRAM: No change.

I'm thinking I need to mount my mac OS partition again somehow.

My partitions look like this:

Device         Start        End    Sectors    Size  Type
/dev/sda1         40     409639     409600    200M  EFI System
/dev/sda2     409640  764763055  764353416  364,5G  unknown
/dev/sda3  976842880  977105023     262144    128M  unknown
/dev/sda4  764764160  976842751  212078592  101,1G  Linux filesystem

where sda2 is my mac os partition.

Any suggestions? I'd very much like to avoid formatting the mac OS partition without gaining access to the documents on it first.

Regards, Cressell

  • As one can see above fdisk can't identify the type of partition on sda2. I'm starting to think that it's a matter of restoring the partition map? But I can't seem to make it work. – cressell Jan 18 '18 at 8:56

You must log in to answer this question.

Browse other questions tagged .