7

I am getting this alert repeatedly. Sometimes but not always, it shows when I start Safari. Sometimes it shows when I quit Safari. It also comes up periodically in the Preview app. I'm not entirely sure how to reproduce it, but it happens a few times per day:

enter image description here

Whenever I see the alert, I enter my keychain password, which it seems to accept, but then the same alert will come up again some time later.

I read in this answer that deleting all files and folders in ~/Library/Keychains/ and rebooting might resolve it. I tried this, but I am still getting the prompt repeatedly. I also get it in Preview sometimes. Not sure why. I have entered my Keychain Access password successfully several times.

I contacted Apple Support about this by phone, and they guided me through "Resetting my default keychain" as per this button:

enter image description here

I did that, shut down my computer, turned it back on again, and I am still seeing the alert.

Apple support also guided me through changing my user password under users & groups.

enter image description here

I clicked "change password" and entered a new password.

This had no effect - I am still seeing the alert. I had to enter the new password in order to dismiss the alerts, but they kept coming back again as they did before.

Also, separately, when I go to Keychain Access to view a stored wi-fi password and click on the name of a network in the list from this screen:

Keychain Access

And then check "show password": Show password

I am prompted to enter my Mac OS User password as I expect:

Keychain Access Wants to Make Changes

I enter the password successfully, and then it shows the same prompt a second time. I enter the same password again, and then it shows another prompt saying that Mac OS wants to make changes to the System keychain and asks me for an administrator username and password with the username and password fields both blank:

Mac OS wants to make changes

I thought this was strange because the username "Mike Eng" from the earlier prompts is an administrator username. Not sure if that issue is related.

Mac OS 10.12.6

  • Thanks. Resetting the default keychain solved my problem of not being able to install Safari extensions. – Andreas Sep 6 '18 at 12:48
1

Mike, It sound like you've got login data for at least one web site stored in Safari, and the browser is having a hard time accessing it. Open up Safari Preferences and click on the "Passwords" icon, then delete everything in there, if that's what you want to do. That should keep Safari from accessing your keychain, but it also means you've lost all your stored passwords.

Safari Prefs

  • Thanks, but I have zero passwords stored in Safari (I just double checked per your instructions) since I use 1password for all my passwords. Also I see this prompt in Preview. – Mike Eng Jan 24 '18 at 3:59
1

I thought this was strange because the username "Mike Eng" from the earlier prompts is an administrator username. Not sure if that issue is related.

This sounds like a keychain issue. Did you recently changed your user password?

If you know your old password, use that password to update your existing login keychain:

  1. Open the Keychain Access app, which is in the the Utilities folder of your Applications folder.
  2. From the list of keychains on the left side of the window, select "login."
  3. From the Edit menu in the menu bar, choose “Change Password for Keychain 'login.'”
  4. Enter the old password of your user account in the Current Password field. This is the password you were using before the password was reset.
  5. Enter the new password of your user account in the New Password field. This is the password you're now using to log in to your Mac. Enter the same password in the Verify field.

macos-sierra-keychain-access-edit-change-password

  1. Click OK when done, then quit Keychain Access.

Take a look at Apple's Support Document: If your Mac keeps asking for the login keychain password

  • To answer your question, yes, I did change my password for the user Mike Eng. I've toggled it a couple of times between two passwords - once earlier on, and once again when trying to resolve this issue. The "old password" in this case would be a password I have had and then not had and then had again very briefly and not had again, so I'm not sure if that will be successful for these steps, but I'll give it a shot. – Mike Eng Jan 29 '18 at 0:12
  • I followed your suggestion, but I got the following error: "sorry, you entered an invalid password". I'm guessing that's because it doesn't recognize my "old password" being the correct password to use in the "current password" field. – Mike Eng Jan 29 '18 at 0:19
  • I tried it using my current password rather than my old password in the "current password" field, and that went through. I'll see if the prompt comes up again. – Mike Eng Jan 29 '18 at 0:24
  • No luck. After changing my password as per these instructions and then quitting and relaunching Safari, I got the "Safari wants to use the local items keychain" alert again. – Mike Eng Jan 29 '18 at 0:36
  • 1
    I put my current password in all three password fields and it worked. Thanks – Rohit Oct 25 '18 at 16:40
1

This happened to me as well. Check in developer mode if you have extensions disabled, if so enable them enter your password and you should be good to go.

0

You might try KeyChain Access (ALT+Spacebar 'keychain access'). Open it and look or search for "Local Items". If you find it, you may wish to delete it, see if that stops Safari from asking.

  • Would that do anything that deleting all files and folders in ~/Library/Keychains/ (as mentioned in the question) didn't do? Just want to check before I end up having to re-enter all my application passwords again. – Mike Eng Jan 24 '18 at 18:16
  • Removing the Keychain file will remove all certs and passwords. I am suggesting a surgical removal of just the ones bothering Safari. KeyChain Access is the 'keychain editor'. – cmason Jan 24 '18 at 19:24
  • Yeah, but what I am asking is would one expect that surgical removal to accomplish anything that removing all certs and passwords by removing the keychain file didn't accomplish? I have already done the latter, so I wouldn't expect the surgical removal to resolve this, unless you have a theory otherwise. – Mike Eng Jan 25 '18 at 16:18
  • No idea, but ~/Library is not the only location of Keychain content. Your root Library also contains them. Keychain Access shows you all certs and passwords available. – cmason Jan 25 '18 at 16:26
  • I tried this, but when I launch Keychain Access and right-click the "local items" from the sidebar, the "delete" option in the contextual menu is disabled. Also, it seems the often-noted way to delete local items is to do so from the Finder as I did before and mentioned in my original question. – Mike Eng Jan 29 '18 at 0:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .