3

Since I updated to High Sierra, me and my colleagues at work have the same problem with our mouse pointer. It appears to be twitchy when switching from the standard arrow to another image (pointer/cursor/...).

I have recorded a gif to show you the problem (the grey area on the left is a button):
enter image description here

It looks like the cursor is jumping to one edge and then back to the center again. This happens with all kinds of pointers. I did not have such a bug before the update. As a frontend developer, I instantly noticed this behaviour after the updates were installed.

First, I recorded this problem with a screen recorder software, but the problem did not appear there as well. I had to record it with my smartphone afterwards.

This bug really annoys me guys. It makes me go crazy... :(

Since three different macbooks (2015 and 2017 model) have the same problem and it was not present before the update for sure, I don't think this can be any hardware problem.

This happens in every program, everywhere. On my external Monitors and on the internal one. It does not matter. My colleague had a fresh macbook pro with the newest updates and he got the same problem.

I found out, that the problem only starts to happen, when I connect an external Monitor. It still happens on both screens, the external and internal though. After unplugging it, the twitch stays present and only disappears after a logout + login / restart. I connected the monitor directly via Thunderbolt 2, ports don't matter.

Version/Build: macOS 10.13.2 (17C205)

  • I filed a bug in the apple bug reporter, looks like this is a duplicate. Hopefully someone will address this issue. It really makes me go nuts all day :D – uloco Jan 17 '18 at 10:17
  • any updates here? – IgorNikolaev May 24 '18 at 9:41
  • There is still no updates on the bug tracker. They have answered me, that this is a known issue and already reported in another bug report, but apple won't provide me any further details or insights. I did not get any update since then and the bug still is present on my both work and private macbook pros (2015 & 2017). :( – uloco May 24 '18 at 11:56
  • One year since opening this issue. Seems like nobody cares :/ – uloco Jan 28 at 8:41

You must log in to answer this question.

Browse other questions tagged .