0

So I just installed Flash and restarted my Mac, and now it won't start. It was working perfectly before that and I didn't drop it or anything.

The power cable works (tried it on another Mac) so it's not that.

When I press the power button I see the charger loading icon and it's red (like 2mm bar) then it takes 2 seconds and the screen is black. No sound what so ever. When I plug in the power cable I can see that it changes from no cable to cable plugged in, but it won't charge or start.

What can have happened and what to do? It's a 2 year old MacBook 15" retina.

Please help

  • Have you tried Verbose, Single User, or Safe mode? Have you run Apple Diagnostics? – JMY1000 Jan 15 '18 at 21:27
1

It is unlikely that the installation of Flash did anything to your power system, it is likely just a coincidence.

How long have you left the charger plugged in to the Mac? I would give it an hour, minimum, overnight is best.

Failing that try resetting the SMC:

...Press Shift-Control-Option on the left side of the built-in keyboard, then press the power button at the same time. Hold these keys and the power button for 10 seconds.

That is from https://support.apple.com/en-us/HT201295 Their article on resetting the SMC.

If that doesn't work it is possible your battery is dead, time to take it into an Apple store or other Mac repair shop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .