I was trying to print this document. It opens great in Preview but I cannot print it:

ERROR: undefined



Trying to print starting from another page leads to a similar error. Any idea? My printer works great on other similar material.

Note that this document is just week 1 of 10 of a class and if I could screenshot and print the jpg page by page I would (I just care about printing) but there are 200 pages total so Im looking for another solution.

  • @PeterJ thanks a LOT but unfortunately it doesn't. Let me post an answer of what finally worked
    – Thomas
    Feb 8, 2018 at 16:35

3 Answers 3


Installing pdftops (and associated tools) worked. It converted the pdf to ps which I could then open (unlike when I directly saved to .ps from Preview) and print


Try clicking Print in Preview, then at the bottom of the window press the drop-down labelled "PDF" and choose to "Save to Postscript".

Now open the Postscript file and print that. The file conversion should (hopefully) ensure that the offending command is gone when the Postscript file is converted back to PDF for printing.

  • so this works on normal pdf files but on this one I cannot open the .ps export :(
    – Thomas
    Jan 16, 2018 at 1:17
  • Hi @jisoegarrd, see my answer below (given by the teacher who wrote the pdf)
    – Thomas
    Feb 8, 2018 at 16:37

I was getting this error when trying to print a boarding pass from WizzAir.

Opening the PDF in Adobe Acrobat Reader and printing from there instead of MacOS preview fixed the issue for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .