0

I have a website which is internal to the company I work for. I am trying to streamline access to the website for our iOS users and I have ran into a problem.

The website is hosted via IIS and if a user is sitting at their desk and goes to the website, they can connect without issue. The website employs Windows authentication, so the account they are logged into on their PC with is used as SSO authentication so they are not prompted for credentials.

I need the users to be able to view the website when out of the office (not connected directly to the company network) but this is where I am having trouble. First, the users would use an app called Pulse Secure to log into a VPN to connect to our network from there iPhone.

The user would then open Safari and go to the website address and would then get prompted for credentials. So I thought to streamline it I could get the users to enter the website url and their credentials into the built-in Accounts and Passwords manager within Settings but here is where I hit a problem.

As my website is not internet facing, the url is in the following format http://apps/mywebsite and as you can see from the image below, iOS does not allow this format of URL as done is greyed out:

enter image description here

The whole goal of this is to stop them having to enter their credentials multiple times. Is there something I am missing or is there a different/better way to do this?

Thanks

  • Not sure this is actually an Apple-specific issue but you need to fully qualify the domain name (EG apps/mywebsite.local) or use the actual internal IP address (EG apps/192.168.0.12) – Steve Chambers Jan 15 '18 at 14:23
1

You need the FQDN, fully qualified domain name, for example apps.local instead of apps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .