2

How do I fix my mail search feature on my Mac? Somehow my mail indexing has gotten "frozen" on my Mac (OS Sierra 10.12.6), so that messages newer than last June do not appear in searches.

This happens for all my accounts (Exchange, IMAP and iCloud), using both Mail.app (Version 10.3 (3273)) and Outlook (Version 15.41 (171205)), and for all mailboxes (e.g. both Inbox and Sent).

When I start typing characters in the search bar of the mail client, the only emails that appear are those older than ~6 months ago. More recent emails do not appear in search results. Even if I am looking right at a recent email, and enter the name of the person who sent it, it won't appear in the results.

Things I've tried:

  • I've tried rebuilding the Inbox to no effect -- even after waiting around for 10 minutes for it to re-download and re-index thousands of messages, I see the same behavior.
  • I've tried moving "Envelope\ Index*" files in ~/Library/Mail/V4/MailData elsewhere to force re-indexing as per these instructions, but that simply resulted in an utterly blank list of emails and no searches were possible.
  • I have looked under System Preferences > Spotlight and Mail is checked. Nothing is entered under the Privacy tab.

It is possible that this behavior is somehow a symptom of the iOS mail client on my iPhone; but an investigation of the phone's mail settings didn't reveal any help re. indexing. The mail is still being left on the server, so it still appears in all my mail clients, it's just that search on my Mac is impossible for emails more recent than last summer. Search on my iOS client works fine.

Any help? Thanks.

  • two questions that may help diagnosticate a possible cause: (1) did you perform a system update at the time the indexing stopped? (I am thinking about "write permission" problems) (2) did you check that the date/time of your computer is correct? (incorrect date-time sync can block the dialog with any servers) – Gio Valerio Jan 12 '18 at 18:47
1

Might it be the case of removing Mail & Messages and adding it back in to the System Preferences for Spotlight?

System Preferences → Spotlight

  • Tried that, no effect. – sh37211 Jan 23 '18 at 21:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .