2

Problem

My VPN dis-/connect workflow script

scutil --nc start "My VPN connection"

isn't working since upgrading to macOS High Sierra (stable Version, v10.13.2).

Details

Context

I used an Alfred workflow to connect to my VPN connections which uses scutil command under the hood.

Dialog with error message

https://user-images.githubusercontent.com/2861556/31211266-02d886dc-a998-11e7-952a-e1409d882a59.png

Translated to english: The IPsec certificate (shared secret) is missing. Please check your settings and retry.

This box appears after trying to start a VPN connetion with the command.


Troubleshooting

I found out, that using AppleScript is working so far. The workaround looks like:

tell application "System Events"
    tell current location of network preferences
        set VPNservice to service "My VPN connection"
        if exists VPNservice then connect VPNservice
    end tell
end tell

My Questions

  • Is this intended? (Didn't found detailed information about this)
  • Are there any new "security related" settings which I have to modify before switching to AppleScript approach?
1

I had a similar issue on macOS 10.12.6.
Root cause was, that I also changed the configuration name of the VPN.

After removing the old VPN and creating a VPN with another name and configuration "Default", it works with both the command scutil and networksetup

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .