1

I'm having a strange problem in macOS Sierra, when trying to connect a remote server via SSH.

I have a key, which I have created it without passphrase. I can correctly connect to the server using that key with Putty (Windows) and CyberDuck (Mac).

However, when I try to connect via SSH using the command line (ssh -I path/to/key user@server) the system asks me for the passphrase.

Any idea what could be wrong? How could I connect with a key that doesn't have a passphrase?

  • 1
    Are you sure it is not just asking you for your account administrator's password? SSH typically required admin authorisation when run from Terminal. If you created it without a password you still need to allow the Terminal to open the session on your (the administrator's) behalf. – ProGrammer Jan 12 '18 at 11:10
  • Try ssh user@server and see what happens – user1256923 Jan 12 '18 at 13:20
  • Is there a reason you're using -I as your parameter switch instead of -i? Most SSH versions I'm familiar with use the lower case i to specify the identity file to use for standard ssh keys, and uppercase I to specify a PKCS11 library. – moneyt Jan 12 '18 at 13:31
  • it is a -i in lowercase... stupid dictionary :D I think the issue is the key is generated with putty and this format is not accepted in ssh – Javi DR Jan 12 '18 at 16:38
  • @JaviDR If you made a typo in the question, please use the edit link to fix it. – nohillside Jan 12 '18 at 18:26

You must log in to answer this question.

Browse other questions tagged .