2

Running osascript -e 'display notification "Message 1" with title "Title"' then osascript -e 'display notification "Message 2" with title "Title"' in terminal shows the first notification then it instantly gets replaced by the second one.

Is there any way to show them both at the same time?

  • If I paste and start your osascripts in my Terminal, BOTH messages are shown and stay until closed. (I am on OSX 10.13.6.) Maybe some preferences of your Terminal app is responsible ?!? – clemsam lang Nov 18 '18 at 0:46
  • @clemsamlang, Your comment reminded me about another issue I had - notifications automatically disappearing after some time, so I thought that maybe the same solution applies to this too, and indeed it does. I tested it and also answered this question. – Iulian Onofrei Nov 18 '18 at 17:34
2

You have to go to System Preferences > Notifications > Script Editor and change the alert style to Alerts:

screenshot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .