1

On December 26, 2017 I took delivery of a 10-core iMac Pro. From the time of its arrival I have had a serious problem with external USB3 drives (I have tried a variety from different manufacturers) attached to the ports on the back of the iMac Pro, ejecting 95% of the time when I wake the iMac Pro from sleep. If I restart, the external USB3 hard drives reappear and function perfectly until the next time I put the iMac Pro to sleep. They do not dismount during use. The only setting I have checked in System Preferences > Energy Saver is “prevent computer from sleeping automatically when display is off”.

To solve this problems I have tried:

  1. resetting the SMC Controller;
  2. resetting the NVRAM;
  3. completely reinstalling the Mac OS High Sierra software using Command > Recovery;
  4. Using a variety of USB3 HD’s from different manufacturers.

None of this has resolved the issue. I am now able to use my new iMac Pro with only the supplied keyboard attached to a USB port on the back of the iMac Pro and two external Thunderbolt HD’s (which do not produce any problems).

Any solution that you can supply to these issues would be greatly appreciated.

  • What is the format of the drives, exFat? I really think it is the USB bus that is the problem, however. Do other USB devices plugged into the same ports exhibit the same behavior? For example can you wake the iMac with your keyboard if you switch to one of the affected Ports? – tekFranz Jan 11 '18 at 4:34
1

I had this problem with a WD 6TB external HDD on wake(encrypted HDD) starting with Sierra and continuing into High Sierra. It would show in Finder (but not libraries or files) and DiskUtility, but would not mount. Running FirstAid failed on the physical disk. All was normal on restart.

Unfortunately It was not seen by TimeMachine and so I ended up with backups without the drive contents. Subsequent backups after restarts ended up erasing all old backups and backing up the entire drive for the next 14 hours.

Uninstalling the WD Utilities, especially WD Utility Helper which runs in background solved the issue. Installing or even just running the WD Utilities executes the helper as well as puts it into the user's startup jobs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .