2

I moved my full photo library from a hard disk "MonsterHD" to an SSD "SieraBoot: to get more performance. I copied the whole directory with all the bits and pieces over (preserving the original one as a fallback.) Then I launched Photos (latest versions of everything) with OPT key down and set up the new location as the photo library. I also clicked "use as system library".

enter image description here

I now want to unmount the old hard disk and it is not allowed because "some apps are using" the drive. When I ask the OS who is doing that, it is revealed that some Photos related processes are still hanging on to the old copy.

~ lsof | grep MonsterHD
CleanMyMa 333 pitosalas   11r      DIR                1,6         68 77730300 /Volumes/MonsterHD/.Trashes/501
photoanal 425 pitosalas  txt       REG                1,6      32768 77294131 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary/private/com.apple.photoanalysisd/GraphService/PhotosGraph/photosgraph.graphdb-shm
photoanal 425 pitosalas    3u      REG                1,6   12193792 77294128 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary/private/com.apple.photoanalysisd/GraphService/PhotosGraph/photosgraph.graphdb
photoanal 425 pitosalas    4u      REG                1,6          0 77294130 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary/private/com.apple.photoanalysisd/GraphService/PhotosGraph/photosgraph.graphdb-wal
photoanal 425 pitosalas    5u      REG                1,6      32768 77294131 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary/private/com.apple.photoanalysisd/GraphService/PhotosGraph/photosgraph.graphdb-shm
photolibr 458 pitosalas   17w      REG                1,6        453 77730301 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary/database/photos.db.lock
photolibr 458 pitosalas   18u      REG                1,6  492240896 77257923 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary/database/photos.db
photolibr 458 pitosalas   19u      REG                1,6     147704 77257925 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary/database/photos.db-wal
photolibr 458 pitosalas   20u      REG                1,6      20480 77257926 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary/database/RKAlbum_name.skindex
photolibr 458 pitosalas   21u      REG                1,6   31117312 77257927 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary/database/RKVersion_searchIndexText.skindex
photolibr 458 pitosalas   22u      REG                1,6      20480 77257928 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary/database/RKMemory_title.skindex
photolibr 458 pitosalas   23r      DIR                1,6        612 72274925 /Volumes/MonsterHD/Users/pitosalas/Pictures/Photos Library.photoslibrary

Any tips on what may be going on? I want to decommission that hard disk totally and I don't want to break my photo library!

  • Did you reboot yet? – Tetsujin Jan 10 '18 at 12:46
  • yes I did reboot – pitosalas Jan 10 '18 at 12:59
  • Have you tried booting the machine without the old drive connected and then try to run Photos? – bjb Jan 10 '18 at 18:23
  • I did do that and it seemed to work... But now (with the new photo files on the new drive) things seem to work except the "people" collection has no pictures. I thought maybe its still processing pictures but it's been two days now! I tried rebuilding the db and that didn't fix it either. I will let jt run more but I am concerned ! – pitosalas Jan 12 '18 at 2:19
1

It looks like you did everything you should.

I have many times made a new photos library, set it as the system library and then rebooted so you're on the proper path there. My hunch is you have iCloud turned on for that library as well and need to resolve that.

I would turn off photo stream and shared photos and restart one time to see if that resolves. If not - you'll need to disable iCloud photo library and walk away from the broken local library or try rebuilding the affected library.

Worst case, contacting Apple support sometimes helps. They often know of edge cases like this where things get stuck and can advise you some hidden tricks to get the libraries unstuck.

  • Thanks. I did have photo stream and shared photos (but not iCloud shared lib). I will let you know how it goes. Asking Apple for help costs money doesn't it? – pitosalas Jan 13 '18 at 14:52
  • @pitosalas Not necessarily. You can start on FaceBook or Twitter for free. When you call in, they will see if the support can be billed with a purchase, but some things get covered when you don't think you're eligible by policy or by exception. They will explain if / when you need to pay. – bmike Jan 13 '18 at 15:16
  • Thanks... I think the situation has solved itself. I followed @bmike idea and unchecked iCloud photo stream and shared albums. Then I exited and launched Photos again. Problem was still there. Then I rebooted. I think problem is now gone! Thanks – pitosalas Jan 13 '18 at 20:37
  • By the way is there an officially sanctioned way to move the photo library from one place to another? – pitosalas Jan 13 '18 at 20:37
  • Yes. Apple help documents it in app for your version, @pitosalas – bmike Jan 13 '18 at 22:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .