2

My wife's default country for creating contacts is the Netherlands. The only solution I've found online is to go to:

Settings -> General -> International -> Region Format

That doesn't seem to do anything. It's already set to the United States. So I went and switched the country to see if it would do anything. Nothing.

Anyone know another way I can set the default country?

  • 1
    I have the same problem, and I suspect I may need to backup her data and reset her phone to fix the problem. – user14633 Dec 6 '11 at 21:00
  • 1
    I did the reset and it did nothing. I have the same problem. I thought I fixed the problem by removing contacts from iCloud. It worked until today when my iPhone 4s froze. After a hard reboot the problem returned. Not only is my default country the Netherlands, it changs some of my stored contact number into an international format. When try to call these numbers it goes to International Assist and won't complete. It also impacts receiving calls where no custom pictures or ringtones are recognized. – user15753 Dec 30 '11 at 20:57
0

This works perfectly if you have Verizon. My default was set to the Netherlands instead of the United States. Turn off "International Assist" in Settings > Phone, then (because this appears to be a Verizon issue) dial *228 to update the phone service choosing option 1. Follow this by calling a second time to *228 and select option 2. Once those updates are finished, power off the phone and start it up again. For me, that fixed the problem and I was able to turn the "International Assist" option back on and it was fine (turning it off may have been an be an extra step, but who knows). This also fixed how the telephone numbers appeared without hyphens. Now all looks perfect.

  • 3
    On my newer phone (iPhone 7+), *228 seems to have been disabled, and supposedly it updates with a restart. This did not fix the issue, however. After much trial and error, I was able to fix this issue by going to Settings -> General -> Language & Region, changing the country to another country temporarily, and then changing it back to my country. I'm not allowed to add a new answer, so I'm commenting on this one. – Luke Dec 11 '16 at 17:23

You must log in to answer this question.

protected by Community Feb 15 '12 at 2:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .