1

I use an external Common Access Card reader to access secure websites for work. This CAC has ID certificates loaded onto it for security purposes and allows access to secure sites. There are different certificates for different sites.

Prior to macOS v10.13.2 it worked flawlessly. Right after upgrading I attempted to use Safari like I normally do, and while I was banging away on buttons, a window popped up asking me something. In my haste, I just clicked clicked yes, and there starts my issue.

I immediately realized that I had never seen that message before. Even the window it was in was a different gold color than I've seen before. I don't know exactly what it asked me, but I'm assuming that it was asking something about using one of those certificates as a default for accessing sites as a feature new to 10.13.2 as opposed to the previous version where I would have to choose from a list of certificates each time I attempted to access a site.

Now, each time I try to access one of those sites, I get a window that says

<com.apple.webkit.networking is attempting to authenticate the user>

and asks for a passcode. Regardless of what I enter for the password, after pressing Enter, the window disappears and then reappears shortly thereafter asking the same question. It will do this as many times as I attempt to press Enter, all while not loading the page.

I have tried deleting all of the certs and websites in Keychain and reloading the certs, but nothing changes. I have searched the web and the computer help search box for this com.apple.webkit.networking thing (I don't even know what to call it) but cant find anything helpful.

How can I find the setting within the computer that is defaulting to this one certificate and remove that action so I can go back to choosing the certificate I need?

  • Most probably you need to check with whoever supplied the CaC & certificates and ask if they are updated to work with the latest system. Also, that first window may have been crucial and could even have asked “do you want to cancel the rights of xxx”, so sounds like you need to visit IT... – Solar Mike Jan 9 '18 at 7:29
1

Have you tried trusting the certificates explicitly? Sometimes, this will help override the macOS system settings.

Certificate options in Keychain Access menu with all options set to "Always Trust"

I also use this site for help: http://www.militarycaccard.us. It has good tips to get CACs and PIV cards working.

0

it sounds like a phish that took your credentials and is now imbedded so deep into your system you don’t notice it. It’s throwing errors thus causing you to no longer access using old certs. because it has reconfigured certs. Reprogram card and base clean not wipe computer ( if you simply wipe it it will still be imbedded and whatever you transferred to hard drive the virus most likely came with it so when you reload you are essentially reloading virus which will start to grow until you are back to this point) as anything you were logged into ie accts passwords etc can and are most likely infected. This has been going on under the “ radar “ for quite some time and unless you have seen the progression, people will think your simply hitting or mistyping. These will embed so deaply and hide so well it will seem as if your computer or phone is not infected. In all reality it was an action you took or made prior to the pop up appearing. Causing the “ pop up” / virus.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .