6

I'm using a MacBook Pro with MacOS High Sierra version 10.13.2.

I used Ukelele to create a custom keyboard layout. I installed it (using the Ukelele installer), and it works fine in some apps, but not others. I can use it in Chrome and in the Terminal (and I am using it to type this description).

But when I open certain apps, like Mail, Notes, Microsoft Excel, and others, it does not work. When I try to select the layout from the drop-down menu like I would in the other apps, it appears like it does in the others, but when I select it, it does not change.

The keyboard layout I created does not have special characters, it is an english layout (abc...xyz) with most characters in different positions than on QWERTY. It is just an obscure layout, so I had to create it myself.

Any suggestions? I am not as familiar with MacOS, as I am coming over from Linux.

3
  • Make sure you have Siri turned off and its keyboard shortcut sent to NONE, and restart. Does the problem persisit? Jan 8, 2018 at 18:22
  • 2
    Put the layout in whichever of Home/Library/Keyboard Layouts and Library/Keyboard layouts it is not already in, and restart. Does the problem persist? Jan 8, 2018 at 18:23
  • Do you by chance have the Chinese, Japanese, or Korean keyboards active? Jan 8, 2018 at 18:24

1 Answer 1

4

@Tom Gewecke suggested in the comments that I place the layout into /Library/Keyboard Layouts. I did this and restarted, then it worked as expected!

Disabling Siri and having its keyboard shortcut set to NONE (and restarting) did not seem to change it. And I did not have Chinese, Japanese, or Korean keyboards active.

1
  • 1
    It seems that the key is to put the layout in both /Library/Keyboard Layouts and ~/Library/Keyboard Layouts. Having it only in one will result in some programs working and others not.
    – Miikka
    Sep 3, 2023 at 14:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .