1

I have a 2012 Mac Mini with a working High Sierra install on a SSD (APFS Volume) in an USB3 external enclosure mounted on /dev/disk2s1 according to Disk Utility

After I moved that same SSD to the internal SATA HD slot, it no longer appears as a boot drive. Disk Utility would still recognize the SSD on /dev/disk3s1 as a SATA drive. Also tried resetting the NVRAM but that did not solve the problem.

I moved the SSD back to USB3 and everything still works fine.

Update

I backed up my data with the SSD connected by USB3 and then tried a time machine recovery to the SSD installed as SATA. Also tried a fresh install to the SSD after erasing the partition. After both efforts, the SSD still will not appear as a boot drive when I hold the option key on startup.

any ideas?

  • I am not sure what you mean by "Bless tool was unable to set current disk." Did the partition/volume appear in the Startup Manager? If so, could you boot to this partition/volume? In other words, did you hold down the control key when you clicked on the arrow? – David Anderson Jan 8 '18 at 11:29
  • The partition DID appear in Startup Manager, but did NOT appear when the option key was down on boot. – michael Jan 8 '18 at 13:22
  • You seem to be going around in circles. I guess I would try creating a USB flash drive bootable version of rEFInd. If rEFInd detects and boots the internal SSD, then we could discuss ways to to move rEFInd to an internal disk. If you have trouble creating the flash drive, let me know. – David Anderson Jan 9 '18 at 3:17
1

SOLVED

I ended up swapping SATA positions on the SSD and HDD so that the SSD is in position 2 (nearest the bottom of the Mac Mini). After that change, plus a Time Machine recovery, the SSD shows up as a boot drive and everything seems to work fine.

I'm not sure why this worked, but it did.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .