3

After a recent upgrade to macOS 10.13.2, Safari has an interaction problem with the Amazon website:

  • Clicking SOME items on Amazon (e.g. Books), a text ONLY description of the book pops up while the item's 1st page disappears. NOTE: This is not a global Amazon problem but intermittent. It happens to only SOME items, but those items it happens consistently. It happens only with Safari and only on the Amazon site.

  • I reported both to Apple and Amazon and no joy. No answers! What's up?

Now, I am forced to use Firefox or Chrome if I want to buy things from Amazon. This has never been an issue before the OS upgrade.

Is this a problem others are facing or perhaps a Safari setting (content block etc) on my behalf?

  • 1
    Disable all Safari plugins, delete Amazon cookies and try again. Does the problem persist? – nohillside Jan 8 '18 at 9:52
3

Introduction
To start with, I can verify that, when viewed in Safari, the content of the Amazon website displays correctly. I am a frequent user (and from your wording of the problem, it sounds like you are too) of their services and have undergone the macOS upgrade (through every version of the High Sierra releases) myself several months ago. Before or after the upgrade, I have not witnessed any of the problems you describe in the question.

This got me thinking that it is most likely an internet, Safari Settings or Location problem as certain content can only be served under certain conditions, e.g. your physical location.

Analysis
Let's begin to eliminate a couple of things:

  1. As you mention that this has occurred after the macOS upgrade (which brought with it a new version of Safari - 11.0) and all was fine before the upgrade, I am almost certain that your physical location (determined by your IP address) is not to blame.
  2. I doubt it is an internet issue (as it appeared instantly since the upgrade), which could cause the website content (i.e. the scripts that serve you the dynamic content such as Amazon listings) to fail intermittently. Visual feedback of such would include very long load times and frequently unrendered website data.
  3. That leaves us with the Safari Preferences and content blockers you may have enabled. Based on my earlier observation that everything displays as usual when I access the website, I would like you to check your own Safari Preferences: Safari -> Preferences for the following:

    • Security Tab: Check that Enable JavaScript is checked.
    • Websites Tab: Go to Content Blocker and remove any Amazon entries from the list. Next, click on Location and ensure that no Amazon entries are set to deny. If you scroll down in the sidebar on the left (where you also found Content Blocker and Location), you find Plug-ins, uncheck any that you haven't heard of.
    • Extensions Tab: Ensure that no extensions added by you (such as AdBlock Plus) prevent content on Amazon from loading. Whitelisting Amazon's website is recommended.
    • Advanced Tab: Select Proxies and ensure that no proxies or VPN tunnels are set, giving Amazon a reason to hinder access.
    • Privacy Tab: Ensure that Block all cookies is unchecked - Amazon required them. You can further delete all Amazon cookies in case Cookie corruption occurred.
      Go to: Privacy Tab click on Manage Website Data... and use the provided search field in the top right-hand corner to search for amazon then click Remove All. This next time you visit the Amazon website, everything is as though you have never been there before, simply log in again and the data you deleted in the previous step (cookies) will be regenerated. This method may prove to be a key step in solving your problem as cookie corruption (although uncommon) has been known to happen between browser upgrades from time to time.

    Cookies essentially store website information between sessions to allow you to get back to where you left off much quicker.

Conclusion
To wrap up, the issue (from what I am gathering) is with your installation of Safari 11. At this time, the latest version is 11.0.2, is this what you have or are there further updates you have not yet installed?
Although I think my answer pretty much covers the essentials, you can read up on resetting Safari if the problem persists. Let me know if that makes sense and definitly how you get on.

|improve this answer|||||
  • Yep. Solved my problem, Thanks! It was either the elimination of Content Blocker or the Extensions eliminated with Amazon plugins that was causing it. I stopped after that to test performance and did not have to continue further. Amazing. Neither Apple or Amazon had an answer but YOU did. thanks again. – Schreib Jan 9 '18 at 3:57
  • OMG. What a fabulous answer. Amazon was nearly unusable for me recently. I discovered yesterday that it was far better with Chrome, so it wasn't my aging laptop causing the problem It turns out you nailed it: content blocker. I turned off the content blocker for Amazon, and now it flies like it used to. Thank you! – Joseph Larson Feb 14 '19 at 15:46
2

There is one more Safari Preference that you should check, on the "Websites" tab. Make sure "page zoom" is not set above 100% for Amazon.

|improve this answer|||||
  • Thank you! This was exactly the cause of my issue. – John Scalo Oct 18 '19 at 5:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .