3

I have a late 2012 iMac i7 16GB RAM and 1TB FusionDrive which I want to sell. Using the Disk Utilities in Recovery Mode, I erased all data on the Macintosh HD partition. I then went on and selected reinstall MacOS High Sierra in the recovery mode, which failed a couple of times (no progress for hours) and after several tries it showed Mountain Lion (instead of High Sierra before) as the OS to be installed. I tried this as well, but the installation process froze after about 7 hours with "3 hour remaining". Then, I created a USB bootable installer for High Sierra. When booting the iMac and pressing the option key, I am presented this USB drive as startup option, and when I select it I end up in the recovery mode window again with the option to reinstall High Sierra. The installation takes about 5 minutes and in the very last second I receive an error message "An error occurred while preparing the installation. Try running this application again".

What options do I have from here?

Note: I already checked the system date, which is current. I checked if there's a recovery partition, and there is a Apple_Boot partition but without the usual name ("Recovery HD"). There are no disk / partition errors when running verify / repair.

  • Weird. No SMART error on the drive? – JMY1000 Jan 8 '18 at 3:37
  • You mean during the disk check? no. That is the weird thing: there's no tangible error or error number provided. I tried to recover the system from a timemachine backup as another idea, but also that didn't work. – Ralph Jan 10 '18 at 0:01
  • Disk Utility should let you know. You can also run this. – JMY1000 Jan 10 '18 at 0:10
  • 1
    It says "S.M.A.R.T. Status = Not supported". See both the main drive and the Macintosh HD partition INFO windows: drive.google.com/open?id=1tFY-0L0gGQpBqPH4HFoRIzySLq89LtWG drive.google.com/open?id=1DpoTCVdst2B5O2buRfLkD-fQi22Y40dl – Ralph Jan 10 '18 at 1:37
  • Apologies, now I see that it says SMART Status = verified in the overview window for the main volume Fusion drive. That confirms that actually everything should be fine, right? Does the volume setup / partition look ok from your point of view, or is there something wrongly configured? Seems ok for me – Ralph Jan 10 '18 at 1:56
1

I finally made it work. It must have had something to do with an encryption I had set up for the FusionDrive previously. SOLUTION: I deleted the Logical Volume Group which resulted in 2 separate 'untitled' drives, i.e. one SSD and one larger HDD drive. I then combined those drives again to form the FusionDrive. After that, I installed the original OS X Mountain Lion via web recovery, installed the High Sierra upgrade via the App Store, and then went back to the recovery mode to erase the volume again and install the High Sierra OS from there. Now I have a clean High Sierra preinstalled iMac, as intended. I would like to use this opportunity to thank all of you for your support, which was extremely helpful for me in finding the ultimate problem solution!!

-1

It sounds like you might have a failing hard drive. Boot from an external hard drive and use a utility like DriveDx (free download with 15 day free trial) to check for errors. This utility does a much more thorough scan than Disk Utility.

  • How to run such a utility when the system doesn't work anymore? I only get to the recovery menu, where my options are the built in Mac options such as Disk Utility, Terminal, Reinstall OS etc. – Ralph Jan 8 '18 at 2:09
  • Good question. I had intended to add that you'd need to boot from an external drive, but somehow I forgot to mention that. – Alan Kinnaman Jan 8 '18 at 5:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .