8

Though the menu bar is hidden in fullscreen, mousing to the top makes it drop down. This really bugs when switching between tabs on certain programs. Is there any way to change this setting?

0

3 Answers 3

1

There is no way to disable Menu Bar display when the mouse pointer is hovered towards the top while running an app full screen.

To alleviate the issue, you may consider switching between the tabs using a keyboard shortcut. Command + { and Command + } works with most of the apps.

1
  • I found a solution, see my answer.
    – The111
    Mar 9 at 1:31
0

EDIT: The solution below is imperfect, but may still be of interest to some. It works when you first launch the app and go fullscreen, but if you then change workspaces and come back to the fullscreen app, it no longer works.

I've finally found an answer to this Q after wondering the same thing myself for many years. Warning that editing the file as described below can break an app (so it's smart to backup the original before you start editing it).

  1. Go to Applications and find the app you want to use in fullscreen mode
  2. Right click the app, then show package contents
  3. Open the info.plist file in a text editor, and add the following lines, supposedly all the <key>...</key> elements need to be in alphabetical order, so you'll need to insert these in the correct place:
    <key>LSUIPresentationMode</key>
    <integer>3</integer>
  1. Save the file, and relaunch the app!

Note that there are 5 values (0 thru 4) you can use, they each have a different behavior.

  • For example value 3 shown above will hide the menu and dock at all times, no matter where the mouse is. Changing to other values will change these behaviors.
  • Note that whatever value you choose, the new behavior applies both in fullscreen mode AND in regular windowed mode, unfortunately I don't know a away to change this, but that is ok since the apps I use in fullscreen, I only use in fullscreen

Source: https://www.youtube.com/watch?v=4KjyVrsXzss (this describes what the other values do too)

0

Go to System Settings > Control Center, and at the bottom, change Automatically hide and show the menu bar from In Full Screen Only to `Never.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .