3

So I used defaults write com.google.Chrome AllowDeletingBrowserHistory -bool yes thinking it would set a mandatory policy for the global (machine) level, but it turns out I was wrong and it set a recommended policy. How do I revert that recommended policy back to an unset policy so it doesn't show as set to any value by Google Chrome? I tried a complete uninstall of Chrome by deleting the app and going to ~/Library/Application Support/Google and deleting the whole Chrome folder and then reinstalling Google Chrome but the policy is still present and shows as set. Any help is appreciated and thanks for your help in advance.

I tried:

defaults write com.google.Chrome AllowDeletingBrowserHistory -bool no(only sets to false)

defaults write com.google.Chrome AllowDeletingBrowserHistory -bool 0 (still false)

defaults write com.google.Chrome AllowDeletingBrowserHistory -bool(syntax of command error)

defaults write com.google.Chrome AllowDeletingBrowserHistory -bool null(syntax of command error)

2

Quit Chrome, open Terminal and enter following (press Return at the end)

defaults delete com.google.Chrome AllowDeletingBrowserHistory

Then start Chrome again.

See man defaults for details about the defaults command and its options.

  • where do I "use" that??? I don't know anything about programing or developing or computers at all, for that matter. I've tried everything else, PLEASE HELP!! – Adrien Jan 27 '20 at 10:37
  • @Adrien Open Terminal.app, enter the command and press Enter – nohillside Jan 27 '20 at 14:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .