5

Recently, I bought the iPad Pro 12.9 inch, 2017 model (as the title says) as well as the Apple Pencil, and I've been noticing a massive number of glitches that have been quite irritating. The glitches are as follows:

Reboot (happened once, but irritating nonetheless) took a very long time, I estimate around 15 minutes. When the reboot finally completed, it displayed the battery as having only 1%, even though it had 65% 15 minutes before. I tried to reboot it, only for no response until after a couple times of holding the power key (might have been that I did not hold it long enough, so I might let that slide as an issue). When it rebooted once more, everything returned back to normal; but that weird reboot session made things seem off.

The Locked Notes in the conventional Apple Notes App constantly have the menu (the one with the various "pens", eraser, selector, and colors) disappear after they lock. The workaround I have found for this issue is to find a note that has no lock on it whatsoever, open that up, and the menu appears back at the lower right hand corner. Then, I have to go all the way back to the locked note, open that up, and the menu is back.

Animations appear a bit chunky, or laggy. For example, opening up the Control Panel (swipe up down from the dock) feels a bit slow. Additionally, there is some noticeable lag when swiping through the apps that appear with the control panel (say I want to close an app or just switch to another).

When I swipe left on the lock screen, or home screen, or notifications screen to get to all the widgets and news, there is some lag as well. Animations again feel chunky. But that's not just it; sometimes the whole entire page just flickers and has to reload everything (reload all the widgets). One time, the screen momentarily locked into that screen as well.

When I reboot the iPad, sometimes I see a white line that flickers at the bottom of the screen and then disappears. This white line appears during the black screen and apple symbol.

The Files app doesn't always show all of the files; in fact, it makes it appear like there are no files in any of the sources at all! Sometimes it works and shows the files in my Google Drive, my iCloud, iPad, and Adobe Cloud, but often it doesnt. Even when it does show files, they sometimes seem to be some old, cached image of the files. It doesn't update as fast as it should. For example, I saved something from online to my iPad (and I was close to the router), and the Files app has yet to register it as actually being there.

When the iPad turns off, it seems to just flicker, almost like it just got shocked, and then turn off. I am not quite sure if this is an error at all; but I would think that the turning off animation would be more of a fade and less of flicker (ideally).

Failure to register the Apple Pencil until after a couple seconds in the Battery Widget. This is weird, because the pencil works fine and clearly must be already connected to do so, but the Battery widget has to reload to show the apple pencil again sometimes. This occurs after the pencil has been in use for some time, and has already been synced with the tablet.

Again, I am new to the whole Apple ecosystem, and I can be overly critical of products. Therefore, I am not sure if I am just expecting too much and these "bugs" are normal, or whether I should contact AppleCare immediately (as this device could be defective).

—————————————(New Updates)

  • Messenger for Facebook now has a defective keyboard. Probably an app problem, but given the plethora of issues I have, probably best to still mention it. The problem: the keyboard stops typing completely. It’s not even laggy, just it won’t simply type. There’s response from the keyboard though, as theres sounds and the darkening of the button when I tap on it, but nothing is getting typed in. As I’m typing this on my iPad right now, the issue seems to only occur for that one app (as far as I’ve seen). Weird however, as to my knowledge there hasn’t been any sort of update.

  • Animations seems to have improved a bit. I think doing a factory reset and wiping things clean made things work better.

  • Reinstalled the stylus app for my iPad, which lets me write using my pencil instead of typing. I can note that issues seemed to arise after installing the app: but not quite sure yet of again.

3

The next best thing is to restore the iPhone software. Meaning erase the software and then using iTunes on a computer to restore the software with a refreshed iOS 11.0.2.

Backup iPhone via iCloud (optional but highly recommended)

Plug in iPhone to iTunes and click restore iPhone. iTunes should also automatically backup the iPhone also. - https://support.apple.com/en-ph/HT201252 **Make sure iTunes is up to date and then restore.

Once restore is done you are going to get the hello screen on the iPhone. Set up the iPhone properly then when you get the Apps & Data screen, restore from iCloud backup (unless you chose not to back it up). - https://support.apple.com/en-ph/HT204184

Then your phone should be back up and working with your stuff back on it and the software glitches cleaned up.

Give that a try 1st then give us a status report.

  • 1
    It seems to have solved most of the problems. However, it has only been one day since I have followed the instructions you have given. I'll give another report after using my iPad for a couple days more. – quantum.cmptr Jan 7 '18 at 3:11
  • 1
    Sure, feel free to keep me posted. – Melvin Jefferson Jan 7 '18 at 4:20
  • 1
    Hm, seems that some issues are back. Chunky animations again, but only when swiping up from the bottom (to access the background apps). Also, the screen flicker issue when turning off. Its chunky animation again: not a smooth fade like I expected – quantum.cmptr Jan 8 '18 at 1:34
  • 1
    @quantum.cmptr ok this time do the same thing, the restore. But don't bring your backup up. Set up the iPad as new a day see if it lasts longer. If it does, then it might be some files on your backup. – Melvin Jefferson Jan 8 '18 at 1:40
  • 1
    No, hasn't done anything really. My original thoughts were wrong about them affecting performance. An effort to turn off background refresh seems to have done nothing, so no apps syncing in the background did anything. New problem noticed: When I exit the youtube app to view all the other apps (with the swipe up to enter multitasking view), normally the video is supposed to play smoothly in its shrunken app window. But however, it plays chunkily, with frames being dropped. – quantum.cmptr Jan 11 '18 at 2:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .